Lining up Subsets

I read that little tutorial about exporting x-files in blender. It mentions that the different objects can be lined up with a linear spread. But how is that done?

And something I’m wondering about: When I load a blender-exported x-file and connect the XFile (EX9.Geometry Load)-node with a Count (EX9.Geometry Mesh)-node the SubsetCount allways says 1. I did like the tutorial said. Shouldn’t there be as much subsets as objects are in that scene? Or did I misunderstand it?

Do you mean this tutorial:

to lign up subsets just connect a transform node to the shader node.

then connect a linear spread to the transform node (to the transform x inlet for example)

your x file just have one subset. make sure to use the exporter mentioned in the tutorial. and you have to assign a material to each obect you want to have as separate subset.

replying to this one,too:
.x to .dxf

I’m using the right exporter/importer ;)

But as soon as I separate some vertices as you say in your tut to make them single objects, I can’t import the file again after exporting it. There the problem with that “index out of range” thing occurs. To me it looks like ben’s importer couldn’t handle his own subsets… if there are any. They should be there because the first object allways gets imported. Only the further ones not.
But vvvv says, that the same file only has one subset and merges all separated objects back to one single object (and I assigned a material to each of the objects).

May you send me or upload a .blend-file with your setup and an .x-export out of that file? I can compare it with mine then. Maybe I will find what’s wrong.

yeah youre right about importing subsets with the importer same for me… i tried first to import an xfile without subsets and that worked fine. i think theres no way to generate subsets in vvvv, and therefore also no way to save them in an .xfile. am i right? so importing .x files exportet with vvvv work…

maybe we should get in touch with ben omari. i once tried to mail him but he never replied?

but at least you managed to export subsets from blender then?

i attached a file that shows how to align subsets in vvvv in a line… and do some other playfulls stuff with it. it also uses texture cordinates created in blender. the blend file is included.

Subset (115.4 kB)

Thank you a lot!

Someone called “rakar” at the Blender Forum took Ben’s script and edited it so that it shows failures while exporting. He also improved (or at least he wanted to) some other things. But the problems stay the same as with Ben’s original one (that index-thing).
And I’m not the only one having this problems.

but at least you managed to export subsets from blender then?

ehm… don’t know. doesn’t look so. I’m watching at your .blend file and you seem to made one or more settings I can’t recreate. Exporting your scene again works fine, subsets are there. But when creating an own scene it fails creating subsets…

The only difference I discovered is, that your letters are drawn in pink when switching to “Draw type: textured”
I will have a look into blender’s manual to find out why.

can you send me your blendfile that doesnt work… i have a look at it… i think the materials are not binded to the objects like the xporter likes it… when you attach a new material there are two buttons OB and ME. im not sure what the difference is exactly but for me it works only when i add the material with OB activated. the bindings in the outliner looks also differnt when you do it this way…

I found what’s wrong ^^

In your tutorial you say: "Make sure that the “OB” button is active and “ME is disabled”. It has to be quite the other way. ME has to be active and OB disabled when creating a material. I did it that way and all of a sudden it worked. :)

thats strange for me its the other way round… i dont really understand that different binding method of materials and stuff in blender… it not really documented grrr i remember i stumbled over that me ob stuff as well and i tried really a lot, and i remember that i once did it the other way and it worked and when i tried later it dindt work anymore…

as far as I understood it ME sticks the material to the mesh itself. OB sticks it to the object. An object is unique in Blender whereas a mesh isn’t. You can create the object “cube” and afterwards you can assign the mesh of a cylinder to it. The object name stays the same, the mesh name changes from cube to cylinder (or whatever it is named to).

Little example: create one cube and one sphere. assign a material to the cube with OB activated. when you then change the mesh from cube to sphere (F9, under Link and Materials, the choice box called “ME: cube”) the sphere has the same color like the cube had because its linked to that object. when you create the material with ME activated and then change the mesh to sphere, the material is “gone” because you have an other mesh to which you didn’t assign a material yet.

I hope it’s somehow understandable…

mh yeah i understand less or more… i think the best thing is t get in touch with omari or the other gui you mentioned… because the documtation of his exporter really lacks a lot of things… you can see that very good in the outliner when you change too “Oops Schematic”

i dont understand why materials are defining subsets does that make sense at all? i thing groups would be a better choice to define the subsets. but i havent a clue about blenders internal datastructure…

i will rework the tutorial if i really really now whats going on there exactly. maybe we should add some instructional pictures too

Can you post your blend file with correct attached materials so i can compare it in the outliner with my working file?

why are materials defining subsets? does that make sense at all?

sorting drawn objects by material is one of the basic optimizations in most rendering engines - so you need to set the material parameters in the graphic card only after a group of objects. subsets can be used for this purpose - and many modellers support this optimization deep down in the oldest part of their code. so it makes absolutely sense if blender does it in the way you´re describing…

Can you post your blend file with correct attached materials so i can compare it in the outliner with my working file?

Sure. here it is. (31.6 kB)

thanks for the mesh… i try out later at the moment im quite busy.