Kinect - "Unable to connect to Device! "

I just bought kinect sensor (USB / power supply), I followed the instructions tried as many combination was possible but without any result.
Machine specs: win 7, 64-bit , vvvv 27.2
last OPENNI drivers :

  • openni-win32-
  • nite-win32-
  • SensorKinect093-Bin-Win32-v5.1.2.1

lately I tried to upgrade the Firmware with last ver. of Asus xtion but without any luck.

Any one has a similar experience ?

thanks in advance

this was the solution for me as was(!) in the relative thread

I installed this package :

Hi vvvvusers,
I have the same problem. I read the kinect documentation and so I installed these drivers:

  • OpenNI (32bit, stable, redist edition)
  • SensorKinect091 (32bit)
  • NITE (32bit, stable, redist edition)

Some time ago, when I tested the kinect with the b27, everything worked fine.

Any suggestion?

do you see primesens sensor in windows configuration pannel ? have you tried ms drivers maybe ? be sure that kinect drivers are correctly involved (if you have installed openni drivers thanks to berkel or zigfu it must be a problem of drivers links).

I realized that it depends (less or more) from your system (32 or 64) , so the solution for our 64bit machine was the same as mentioned by @tsou)) (, for my 32bit laptop was to install from the beggining the newest drivers as I found them in the list of ((forum:the-kinect-thread.

i have the same problem right now…

nothing is working neither OpenNI manual installation nor brekel.
Strange thing about that: i had already successfully connected my kinect to the Computer before with OpenNI.
But after a while of not using the camera its not working anymore and i changed nothing!
The System detects the kinect (even if i think the drivers do not get installed proper or maybe not all…!?) but VVVV and ReconstructMe do not and throw exceptions.

So i deleted OpenNI and installed Win SDK -> works out of the box with VVVV and ReconstructMe.
Kinect works with OpenNI on another Computer.

Its very strange because i really did not change anything…

Kinect works with the MS drivers. If I install the openNI drivers as written in the the kinect documentation Kinect (Devices OpenNI) tells me “Unable to connect to Device!”. I tryed to install another version of SensorKinect, also with Brekel package: in this case Kinect (Devices OpenNI) tells me nothing.

Is there someone that uses Kinect with openNI drivers and b27.2?


I do, but as I mentioned before both solutions-on different machines-worked for me. I recommend as many on this topic to uninstall completely the drivers, check your device manager again (that everything has been removed) and re-install them. Another way to test if drivers were succesfully installed is to try them via OSCeleton, worked for me.

I have the similar problem says unable to connect to device. so in order to use openni we need to remove ms drivers? MS SDK works perfect though.

I had the same problem and the solution for me was to run vvvv as an administrator…

@vasilis: which drivers version are you using?

@Alec: the one that tsu said on top of the page…

this one

I can’t fix the problem. Renderer (TTY) node shows some errors.

Any suggestions?

It’s a problem with the drivers because if I install the Development Edition and I launch a demo appears the same error: “Can’t create any node of the requested type!”

How can I fix this problem?

Thanks guys…

Hello, recently I was installing this, I tried
SensorKinect093-Bin-Win32 v5.1.0.25
SensorKinect092-Bin-Win32 v5.1.0.25
and does not work.

attach SensorKinect091-Bin-Win32-v5.1.0.25 that is no longer on the page to download. ( (4.0 MB)

I finally fixed the problem: I created a new licenses.xml file with the same content of the original file and I overwrited it in the “Data” folder, inside the OpenNI installation folder.

Now all works with the OpenNI drivers that are listed in the kinect documentation.

SensorKinect091-Bin-Win32-v5.1.0.25 is attached in the previous post by @obernardoo.

How would one go forth to make a this new licenses.xml file?

for me kinect works finally (on winxp, v4beta28.1) with the following drivers:

SensorKinect091-Bin-Win32-v5.1.0.25 which is attached in the previous post by obernardoo
(with “SensorKinect093-Bin-Win32-v5.1.2.1” it never worked. the kinect node could not detect/connect to the camera)

i did not create/change the licenses.xml file (as written in the previous post from Alec).
was no need to do that.


I tried every solution but I still get the “unable to connect to device”

I’ve download the drivers from the forum/kinect page and from here too

but none of them works…I also rebooted the pc with the option to allow unsigned driver mode…nothing though…

Run as administrator (that worked for me before) nothinga again…

Tried older versions (nothing)

Any other solutions?