Kinect Problems

Hello vvvv,
I have problems to get my kinect running with beta28.1.

Tried this:

  1. Followed the instructions of kinect. Didn’t work, Kinect Node says:“Unable to connect to Device!”, Kinect-Sensor is blinking green.

  2. As mentioned in the Thread, I tried the Brekel Driver Package. This is what happens: After installing the Drivers, the kinect is not working in vvvv. The little LED on the sensor is blinking green. BUT: When I started the Brekel software, everything is working (and the LED is constant orange). If I start the kinect after that in vvvv it still says “Unable to connect to Device!”, but I can get the RGB and Depth image:

Unfortionately the other Nodes like sceleton or user aren’t working.

Anyone knows whats the problem?

Has anyone a kinect running properly? What Drivers are you using?

Thanks for your help!

Cheers, Gerrit

Hi Gerrit,

i have my Kinect running with the Microsoft drivers (and kinect nodes) - without problems. I am using version 1.5, but will upgrade to the new release soon. Microsofts SDK / Drivers are backward compatible so you should not get any problems running the recently release 1.6 version.

Hi ethermammoth,
thanks for your reply!
After deinstalling and reinstalling the Drivers several times my kinect finally works with the Microsoft 1.6 Drivers. OpenNI still isn’t working. But thats ok for me.

hi gerrit! just received a cheap kinect. went through all related threads and checked the driver sources. and i´m still confused. to avoid driver problems. i´m still using xp( on bootcamp). do you use xp or win7 with the windows drivers?

Hi sinus,
For me it worked both on a Mac via bootcamp with win 7 and a “normal” PC with win 7.

One thing you have to be careful with, is to make sure that you deleted all older drivers properly before you install the new ones.

cheers, gerrit

thx for the prompt reply. so will the microsoft drivers work with xp? any users still running xp and using ms drivers?