Kinect 2 Red Nodes

Hi Guys,

I just received Kinect 2 sensor…Well I’m trying to connect it but it seems that whatever I do it doesn’t pick up the nodes…Any ideas…I’m pretty sure I’ve done everything by the book. Kinect 2 node seems OK but the rest don’t.

Any ideas?

Ah…Just to say that I use the latest beta

the kinect2 nodes are part of the dx11 pack. so remove the kinect2 pack and try again.

It just makes things worse…I don’t even get the node list now…

Just to mention that I installed the sdk and the runtime for windows…

Screenshot of red nodes does not help much, there could be hundreds of reasons why a node does not work.

Steps I usually do when trying to solve situations like this:
1 - Open Renderer TTY and see what it says
2 - Try Procmon, is the vvvv.exe failing to locate dependency or access files, resources?
3 - Download everything again VVVV, Adons, Pack, double check they are all build for same architecture (x86 or x64), unpack to a new folder with Winrar or 7zip. Run Setup.exe, all boxes green? Try on different machine.
4 - Hurt me plenty: Clone github repo of the DX11 pack, compile in VVVV as debug, copy the deploy to packs, run vvvv, attach to process, breakpoints.
5 - I’m too young to die: Hire an expert let him/her solve over TeamViewer.

Prolly VC redist, you can check that quickly if dx11 text works

Ok…I will have another look again and I will update the topic.


OK…I tried a couple of things and finally I think it had to do something with the packs folder…I copied the pack folder from Node 15 workshop of dx11 pointcloud ( and it worked…So I don’t know what’s special in there…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.