Kinect 2 'not enough USB controller resources'


running 8.1/SDK2.0_publicpreview1407/Kinect 2 PC

drivers load fine, but when i run depth basics or kinect studio i get a ‘not enough USB controller resources’ popup, and the KinectSensor device drops in and out in device manager

not tried with vvvv/dx11 yet

clevo w860cu notebook, intel 5 series 3400 chipset, NEC USB 3.0 hardware, driver is Renesas USB 3.0 eXtensable Host Controller -0096 (Microsoft)

i tried adding a powered USB 3.0 hub but no change

is this a power or data bandwidth issue?

anyone know the minimum usable values for voltage and bandwidth?

has anyone used an USB 3.0 expresscard successfully with the kinect 2 pc?

thanks everyone - hope i can get it working : )

looks like pre 2011 usb 3.0 controllers are a little iffy with the kinect2PC
ms support suggested controllers with intel or renesas chipsets - so i bought an $8.56 (shipped!) expresscard on ebay that has renesas drivers, hopefully that will get things working
probably time to buy a new notebook though… : )

ms forums posted a partial list of working (and not working) controllers here

same problem here with a macbook pro 2011 -> belkin thunderbolt express dock (with a fresco usb3 chipset). after updating the driver at least i get an error message in the device manager:

This device cannot start. (Code 10)
Current device power state cannot support this request.

too bad, i was hoping the express dock would do me the favour of letting me play with this new toy.

@@ghosts: thanks for posting!

i really often had usb-issues and lots of them caused by insufficient powersupply.

one example:
active displayport->DVI duallink adapters which made use of USB only for powersupply reasons.

after lots’n’lots of hours testing i noticed that during startup of Windows, when the graphics adapter tried to evaluate its connected devices, the adapter’s current demands suddenly increased from 0mA to 340mA und few seconds later back to 0 mA , then again 340mA and so on for 3 or 4 times.
this is quite a task for the regulation circuits in switched power supplies.

it turned out that it was essential for the device evaluation to fulfill the power demands immediately.
the solution was kind of simple: an external USB-hub (no link to the pc needed) with a WAY OVERDIMENSIONED powersupply-adapter (something like solid 5V 3000mA)

also i recommend not to trust mainboards manufacturer’s specs about current/USB too much.

recently i stumbled upon a very nice free tool by microsoft that provides very detailed information about all your USBstuff:

check USBview
wish i’d found this earlier.

maybe a little OT from your problem,but…

good practice after installation of itchy devices that ask for OS restart:

do not restart, but

*shutdown computer
*disconnect mains cord
*switch computer on
*look at any visible LEDs on mainboard etc. to make sure that
*all Capacitors are completely discharged
*connect mains again
*startup computer
and wonder about how easy life can be…

helps more often than you may assume!