Jump value

This is probably a known one…

When getting back the LFO cycles via = and a framdelay(If the lfo is set very fast), the value is just ignored…sometimes it works sometimes it dosen’t…Doesn’t work if you do something inside the patch or move the window, and happens sometimes at startup…I don’t know if this comes from the LFO, the = or the frame delay, but i suspect LFO to miss some values sometimes…

any workaround?

jump.v4p (3.2 kB)

with the given period cycle value may change faster than your frame rate. so there HAVE to be value drops.
giving a little more tolerance with “epsilon” already helps.

but in your case i would use a > (Value) instead of = (Value) anyway.

jump.v4p (3.8 kB)

You’re right >= works like a charm…Thanks!

If you need a counter that goes as fast as your patch is running, just use a counter with the Up-pin set to 1.

Or use your method, but use a >= node instead off an = node.

yep counter is an option but i wanted a speed slower than counter…anyway tx!