It would be useful to have the possibility to “hide” the Descriptive Name in the Inspector, so that no Inlet (from the subpatch) is created.
I usually use Descriptive Names for describing important IOboxes - and not all of them are meant to be an inlet too.
Using the field where the Pins can be hided as well would make sense for “hiding” the Descriptive Name. It could then turn into a different funky shade of grey!
(Another solution would be the possibility to group nodes/ioboxes with describing texts which were created by double clicking)
hm, if you don’t want a described iobox to turn up as an inlet in the parent patch, you could hide the corresponding pin (of your patch, as a subpatch, in its parent patch) - after all, every patch is a subpatch, all inputs are pins, and all pins can be hidden :)
i see your problem, though. i just don’t know what i think about shifting the ability to hide an input from the parent patch (‘i don’t want to _see_this input’) to the containing patch (‘i don’t want to _show_this input’) …
when designing that feature/limitation we liked the idea, that everything worth naming is automatically visible in the parent scope. obviously this misses the distinction between constants and variables.
on the other side its also a workable convention to use descriptive names only for variables and comments for constants.