Improve performance

Hi there! I have a patch with 12 subpatches, each one is a different step of my performance. I’m trying to keep the framerate around 25fps, so I’d like to have a low “number of thousands of ticks” for my subnodes, at least when I’m not using a subnode.

To do this I put a NIL value in any pin of the subpatchs I’m not using at the moment. In debug mode (CTRL+F9) I see that in this way some node reduce drastically the number (400->60) some others by the half (69->30)

There is a way to bring this number to zero? How can I make something like AutoEvaluate = false for the subpatchs?

You can also use the tonfilm´s svvvvitcher technic with create node, but it freezes a little during the switch.


S+h is your friend…

The debug-mode number is lying to you, don’t make too much of it.

can we learn the trick?

@DiMix: As long as set pin is not set to 1, S+H will not evaluate upwards nodes (unless some are with autoevaluate). So if you have some large statuc spread you only need to evaluate once you can just use this pin to generate, then all the logic on top won’t be evaluated.

@gilbi Debug mode numbers are pretty accurate (apart for little low spreadcount nodes), don’t forget update/render are not included in that part but in the final renderer.

@Luper: being able to switch node evaluation at runtime is not possible so far, would be prett one of the top on my wishlist ;)

sometimes i dream of a hidden evaluate/enabled every (sub)patch could have… like the Patch or ID.

with such a pin, that really stops a subpatch while freezing its outputpins’ content, patch-optimization would be much easier than with thousands of s+h and switch

see it as a feature-request…

I like your dream sebl :)

it would be great.

+1 for sebl’s request

here here.

+1 (obviously)

I think we already discussed “enable” feature in another topics. Btw, it’s still not implemented, so +1 for it ).