Imported 3d model not rendering properly


I am making a football game installation for which I am using a ready-made 3d model from Google sketchup.

So I got a model from the warehouse, exported it using this plugin :

but when I import it in vvvv, it is not being rendered properly. Some of the faces are hidden or dark.

This is how I want it to look

But this is how it looks:
Full res screenshot :

Please help me solve this issue.

The patch with the x-file and textures (1.6 MB)

choose a back buffer format that supports depthbuffer in the renderer and then set a depth buffer.

then set near plane to something other than 0 in the camera, eg. 1

then it should be rendered properly

Also to check in general:

  • that your normals are pointing the right way
  • that your texture assignments are ok
  • if you need texture with alphas in 3D scene try alphatest node

i’d use collada instead

would not be better to use the mesh own vvvv …

Thanks a lot for the replies .

@sunep : Those 2 changes solved the visibility issue. Now all the faces are visible :) Thanks !

However, some faces were appearing black, which, as everyoneishappy pointed, was possibly because the texture assignments were not ok.
However, even after assigning the right textures, some faces are not getting the texture. They are grey. Please see this screenshot :

@everyoneishappy : Thanks for the suggestions, but I’m a noob, so can you please tell me
How do I check whether the normals are pointing the right way ?

@antokhio : I had previously tried collada export from sketchup, but the colladafile node outputs a null value when the file is given as input. Same problem for my other exports from sketchup too. Please see this screenshot :

@dannielmach : Sorry I didn’t understand what you said. Can you please explain ?

check you don’t export camera, seems happens quite regular with camera inside file, it’s also might be you exporting poly and not a mesh
put this collada file i’ll check it in max

@antokhio : Thanks, please see the attached dae file.

How to set the options in sketchup free version? I only get these export options :

stadium collada (5.4 MB)