Import Character Animation (bones/skeleton)

I’m want to import a character animation in vvvv. Tried several attempts without luck. The original format is FBX. When converting it to DAE (from C4D), it does not appear in the ColladaAndSkeleton batch at all. When converting it to BVH (from Motionbuilder) for the BVH node, the hierarchy/position/rotation is totally messed up. Any suggestions?

still no easy way to do it, see here

That’s an awesome tutorial. However, I need to get the character animation from the imported file (FBX, DAE or BVH) rather than animating it in vvvv. Would be quite okay if I only get the joint positions – skinning is less important for now. Tried to load FBX and DAE, but always get a NIL.

it’s in that tutorial too starting from

Thanks for the hint u7angel and microdee. This helped a lot.
I am now using the SceneFile and SkeletonSimple nodes to load the FBX. The SkeletonSimple has output pins for Position and Rotation. The Rotation values seemed to be fine, but for the Translation, only 3 values (one 3d vector) are updating, while all other numbers freezing. I tried a workaround by using GetJointTransform and Decompose, which somehow works, but the slice numbers are quite different from SkeletonSimple. SkeletonSimple has 58 Nodenames and 174 PositionsXYZ. From the Decompose GejtJointTransform I get 276 TranslateXYZ. Any ideas why the number of slices are different, or why the SkeletonSimple does not update the PositionXYZ?

sounds like you have some hierarchy problem out there, if u can upload a patch and mesh, there are some binsize problems sometimes, also the keys have to be baked to single animation track, i would go for DAE format however u need make sure that exporter is 1.4 collada and not 1.5

Attached the patch, FBX and C4D file. DAE isn’t working. The number of sliced I get from Decompose corresponding with the actual bones in C4D. By shorten the animation or baking frames, the number of slices from the SkeletonSimple (last three output pins) even decreases. (589.9 kB)

Reason: skeletonsimple outputs relative transform only for animated bones. with characters most of the time only the relative rotation changes, so proportions are kept. GetJointTransform on the other hand outputs absolute transformation about every skeleton (including the ones without relative animation) and that’s why you have more slices there with moving translation

Hmm so… your mesh looks destroyed…

You also don’t have texture coordinates (UV) on your mesh so it won’t work on any shader with texture on input…

also you have some wierdo transform on your skeletonso if i decompile it in maya it looks offsetted

there is bit of stuff modeling package does for you, but when you export u can expect all type of shit you had in pipeline don’t work as you expect…

Unless u break down it fully to clear hierarchy with baked everything and without wierdo transforms it won’t work…

And try to find collada 1.4.1 exporter for C4d, if u mange to make it export proper most likely it will work

Many thanks for the explanation. Got it. For now, it’s fine to work with the vector points. Will try to fix the mesh at a later stage…