Forum

HTMLTexture bugs driving me crazy

Most of the time HTMLTexture simply works, sometimes it just crashes (completely, without error message). These are messages from the Windows eventvwr:

Anwendung: vvvv.exe
Frameworkversion: v4.0.30319
Beschreibung: Der Prozess wurde aufgrund einer unbehandelten Ausnahme beendet.
Ausnahmeinformationen: System.AccessViolationException
Stapel:
   bei SlimDX.DataStream.WriteRange(IntPtr, Int64)
   bei VVVV.Nodes.Texture.HTML.HTMLTextureRenderer.WriteToTexture(System.Drawing.Rectangle, IntPtr, Int32, SlimDX.Direct3D9.Texture)
   bei VVVV.Nodes.Texture.HTML.HTMLTextureRenderer.Paint(CefGlue.CefRect[](), IntPtr, Int32)
   bei VVVV.Nodes.Texture.HTML.WebClient+RenderHandler.OnPaint(CefGlue.CefBrowser, CefGlue.CefPaintElementType, CefGlue.CefRect[](), IntPtr)
   bei CefGlue.CefRenderHandler.on_paint(CefGlue.Interop.cef_render_handler_t*, CefGlue.Interop.cef_browser_t*, CefGlue.Interop.cef_paint_element_type_t, Int32, CefGlue.Interop.cef_rect_t*, Void*)





Anwendung: vvvv.exe
 Frameworkversion: v4.0.30319
 Beschreibung: Der Prozess wurde aufgrund einer unbehandelten Ausnahme beendet.
 Ausnahmeinformationen: System.BadImageFormatException
 Stapel:
    bei CefGlue.Interop.NativeMethods.cef_string_clear(CefGlue.Interop.cef_string_t*)
    bei CefGlue.Interop.cef_window_info_t.Free(CefGlue.Interop.cef_window_info_t*)
    bei CefGlue.CefWindowInfo.Finalize()

The first one comes really often, the second one only a few times. Not sure what I’m doing wrong (or what I even can do wrong).

uiuiui
same here!