How to disable videotexture

Hey guys:
I was wondering if there is there a way to ‘disable’ a videotexture node? The situation is as follow:
we have a huge patch which is running several shaders and spreads. We want to play a video file that is streamed from a blackmagic intensity pro video card. The source of the video input is another computer. We have tested this before and it works super fine(nice HD quality texture input!). However, when clustered together with the other part of the system(shaders and spreads) the framerate drops badly and the video sttuters a little bit. So far a good solution has been to disable part of the geometries in order to gain some gpu power. I am wondering if it is possible to do the same with the videotexture when it is not being player, that is, to disable it. So far you can disable the billboard where it’s been projected but not the videotexture itself. It seems that it’s still consuming some cpu power even when the billboard is off. Any suggestions?

thank you!

hi efe

If you haven’t, try setting the “wait for every Nth frame:” pin on the video texture node to 0 that might cause the frame Rate drop. if set to 1 it forces the frame rate of the whole patch to the framerate of the video texture.


Hey Sunep, thanks for the answer!.

The patch was already very low on framerate(it is very heavy) but it didn’t make the image stutter. The framerate and resolution of the texture input is very high(as it comes from the intensity pro), so if we try to sync the framerate of the input to the framerate of the patch, the image starts to stutter and gets slightly glitchy. Any ideas how to fix this?


my be a crossfire between the two graphic cards? I am shooting in the dark here!

you didn’t comment on suneps suggestion. did it not help? also try the Enabled on VideoIn (DShow9).

Hey joreg!
we will try that now, hope it works. I will post the results!

update: the videotexture had such divergent framerate with the rest of the patch that it had a lot of stutters and frame drops. The trick was to move manually the framerate of the videotexture in accordance with the general framerate. That simple!

thanks for the help guys!

efe, how do you change the framerate of a videotexture?

On the videoIn node as joreg and sunep suggested. Still i got a huge stutter at the beginning because of the stream coming from the intensity video card(the framerate of the whole patch was rather slow!). We even tried a crossFire with two ATI cards in order to check if having parallel devices would help the system. Anyway, the trick was to move by hand the fr pin of the video in according to the fr of the main patch, then calibrate it manually accordingly. Maybe not the most elegant solution!