Hide subpatches from node list


#1

Hi Community,

I would like to know how to hide subpatches that appear in node list, I make a little Keyboard GUI for all of us, but my subpatches appear in node list, it’s not dramatic, but useless to use it in other case that mine.

LOVE VVVV !!!


#2

afaik you can add “Internal” as tag to hide them…
so your patches should have a name like that:
nodename (category Internal).v4p


#3

Great, it’s working :-)

Thanks !


#4

@Bartuc great!

one thing: please remove the “,” (comma) from the modules name, ie from:

Keyboard (DX11.Layer, Touch).v4p

to

Keyboard (DX11.Layer Touch).v4p

to conform to the vvvv naming sheme.

and regarding your question: actually your subpatches do already not show up in the nodebrowser for users of your pack. only if you open one of your subpatches (which users typically don’t do) the patches available from there, locally, show up. it is like that, because your \subpatch path is not part of vvvvs searchpath!

only in case modules happen to be in a searchpath you can hide them by setting a version of “internal” on them. again, in your case: not necessary.


#5

Done !
Thanks @joreg for this tip :-)