Hardware accelerated video problem

hi there,

i’ve wasted hours now to figure out what’s wrong.

all i try to achieve is hardware accelerated video playback inside vvvv (which apparently should pose no problem with the right hardware but seems to be impossible for me to achieve).

here’s my setup:
. macbook pro with nvidia geforce 9600m gt (is dxva2 capable)
. codecs as explained here: https://discourse.vvvv.org/t/7131 (and 100ds of other combinations)

what works (checked with gpu-z and dxva checker):
. hardware accelerated playback of WMVs with windows media player
. hardware accelerated playback of H.264 with windows media player (using the ffdshow dxva option).

what doesn’t work:
. hardware accelerated playback of wmv/h264 inside VVVV (using FileStream->Videotexture). the media content subtype of the video texture is: Unknown: {3231564E-0000-0010-8000-00AA00389B71} - which might be the cause but cannot get rid of.

. hardware accelerated playback of wmv/h264 in graphedit (actually i’m using http://blog.monogram.sk/janos/tools/monogram-graphstudio/).
the graph reveals (for the wmv-file) a WMVideo Decoder DMO that is responsibly for decoding. after some reading i understood that the DMO playback chooses by itself whether hardware decoding can be used or not. i have no idea why it should work with wmplayer but not in VVVV or graphstudio.

any ideas?
i’d love to try one of these nice little AMD fusion (e-350) systems as a kind of extended video player soon, but for this little thing hardware acceleration in vvvv is crucial.

thanks for any hints!

I have been wondering for quite some time how you could enable DXVA in ffdshow.

As it turns out, it can only work if you select ‘NV12’ as output color space in ‘ffdshow video decoder configuration’. I made a simple patch playing a WMV-file (and in ‘ffdshow DXVA video decoder configuration’ I had H264 and VC1 set as ‘DXVA Codecs enabled’).

My GPU-load would be

  • 6% if I didn’t check NV12 (CPU load of more than 50%)
  • 12% if I did check NV12 (CPU load of around 35%)

This seemed to be the key in my case, and something that no one ever mentions, so if it’s not the case for you, I hope this information at least helps somebody else out :)

(I used YUVMixing Mode Texture)

unfortunately that does not help me either (i tried that before). thanks anyway!

i noticed one odd thing: when playing back the WMV with windows media player gpu-z shows a utilization of the “video engine”, which it does not when played back in VVVV. anyway, there is a noticable difference (+15%) in gpu utilization when played back in VVVV, so i might get some hardware acceleration after all - it’s just not correctly labeled (but that’s just a presumption - it might also have a different cause like video data being pushed to the gpu for displaying). and it does not solve the h264 problem…