GeometryFile (DX11 Assimp)


#1

Hey guys,

Any clue why GeometryFile (DX11 Assimp) is not reading any of my 3D models??

I tried lots of different formats, plus I passed them through a repairing tool… Nothing…It doesn’t even pick them up (Output bin size = 0)

Does it have a limit on the size?

Some models that are less than 1mb are loaded…but models with size 20mb or 30mb can’t get loaded

any tips? except from getting my model below 1Mb size…It was 2GB and I’ve managed to take it to 24Mb…I don’t know if I can go less.

Thanks


#2

GeometryFile node for importing spread of small objects, maybe that’s what causing the problem…
There is bug with assimp nodes, but that’s more of 3d exporter problems, bug called 0 vertex subset, appears when 4d exporter creates some sort of dummy object, There will be an error on shader pin tho…

I can suggest you to use scene assimp instead, there is also node called sceneexplorer(assimp) will show you what’s inside of your file

SceneLoader (DX11.Geometry Assimp).v4p (9.1 KB)
this module proved to be minimum amount of nodes to work with 3d files

also you can upload one of your meshes to check them out

there is this thing for windows if you can test model with it http://www.open3mod.com/

also when you are using geometry file, there are no predefined transform so your mesh could be 100000 bigger then what cha see, also check of you don’t have troubles with texture coordinates (uv)


#3

Thanks antokhio once again…I will ckeck them out and report back

Here is the model…Even with SceneLoader it doesn’t find any info…

https://dl.dropboxusercontent.com/u/49260563/Agios%20neophytos%20exterior-interior.STL


#4

@vasilis your mesh is totally fine, it’s just huuge scale and moved off center…
agios.v4p (9.0 KB)


#5

Ok then, something is wrong…My model wasn’t there because the output is either NIL or 0…

I’ve download your patch, I didn’t changed anything (only the path to my model) and I get NIL values…how this is explained?


#6

Maybe you are missing vc_redist… try to go to download page and manualy download all the vc_redist’s i think you need 2013 for assimp


#7

Absolutely nothing! I’ve unistall everything, reinstall everything nothing…I opened the TTY renderer and it’s flickering…it’s showing this:


#8

does open3mod works?


#9

Yes it works

I just tried it in another pc and it works…but not on this machine…so something is up with my machine…is not the model or vvvv


#10

can you try re download vvvv & dx11 pack? sometimes it’s getting corrupt while unzipping


#11

OK Finally made it!!!

I’ve download again vvvv and dx11 pack as you advised me and I did extract them with 7zip just to be sure but again nothing…so I’ve download the 64bit version along with the DX11 pack plus the DX11.pointcloud stuff…When I clicked on the setup I had two red boxes…I did the appropriate installations and now it’s working…

Thanks antokhio!!


#12

Yes with even moderate sized models the x86 assimp stuff just gives up, best to always use x64 with it. I have yet to give x64 too big a model for it to load.


#13

coming back to this…Is there a way to make it work with x86 or I need to use x64 all the time?

Because I would like to use it along with metaio plugin which works only on x86…so one of them needs to work in both…

the x86 to work needs a very low size model? Like some KB?


#14

I will answer this to myself…

Yes it works in x86 if you reduce your file to a very low size…10 mb and below…for example at 17.mb it wasn’t working but now at 1.97 Mb it is.


#15

Again Coming back to this…

Is there a way to retrieve the info that I see in scene explorer (RootNode) into my patch??

I would Like to use this info, furthermore I would like to know which one is which…

It’s a 209 parts model…so obviously I can’t remember which one is which.

cheers


#16

that’s a bitchy part, i’m usually doing this by applying different colors to the parts i’m interested in
i think there was a way to get names of the objects somewhere (maybe on old collada dx9), but that’s about it…


#17

hmmm…The thing is that I’m interested for all 209 parts…So bit tricky…Seems that I will need to do it manually. and that will take a loooooooooong time…


#18

Well try all the assimp related nodes, maybe you’ll get something usefull… there might be also some hidden pins somewhere vvvv style you know ;)


#19

Haha!! yeah ok, I’ll try that!

Thanks


#20

It seems like “Node” assimp does the work.