Generating procedural mesh from buffer

are the normals flipped maybe? you could try to invert them…

Concerning problem 2:
Normals have been flipped indeed! Thanks for the suggestion @tonfilm. But flipping them did not make the lights work. So after some random experimentation I found out that overwriting the ShadowMaps had an effect in my case. Don’t really have a clue why though. It behaves like this at the moment:

Point Light only works with ShadowMapSize set to XLarge.
DirectionalLight works with and without overwriting the ShadowMaps. However, if the external ShadowMap node is plugged in and I navigate through 3D-Space there are a few angles where the directional light suddenly goes black.
The SpotLight worked from the moment I plugged external ShadowMaps in. Now I can sometimes unplug ShadowMaps or change them how I like and it keeps working, but sometimes it goes black when I unplug the external ShadowMap Node. Maybe there is still some mistake concerning my normals, but this all seems very strange to me.

Little addition to problem 1:
At the moment I’m just calculating face normals in the geometry shader so the normals don’t look smooth. However, I have point normals, tangents and uvs in my buffer, which have been calculated with a compute shader. I’m just not quite sure where I can set them in the vertex stage of the SphereImpostorMaterialExtension as mentioned above.

Playing around with this a bit more I find it really useful and opening up a lot of possibilities and there are a few more question coming to my mind. Is it possible to use the normal and displacement input of the pbr material to add a normal map on top of the procedurally calculated normals? Same question for the displacement. And would it be possible or generally make sense to instance a procedural geometry with this set up?

Thank you for your help with this so far! :)


Check your graphics drivers maybe they need updating, I had transparent materials fixed with an update recently.

Good call @catweasel. Haven’t tried that before. I’m on latest Nvidia studio driver now, but the light problem hasn’t changed unfortunately.

@maxs are you setting the bounding box of the mesh? the bounding box of the input mesh should roughly match the geometry that gets generated. this is important for culling and shadow map partitions.

yes, that should be possible. so as you noticed already, overwriting the whole VSMain isn’t the best idea, because the VS does a few things that the materials and the shadow map renderers need. so if you override the 3 transform methods as in the example, and do what they are supposed to do, you should be able to add a normal map on top of it. i am just not sure which stream variables you need to set. maybe have a look at what the stride transform shaders are setting. it shouldn’t be much, probably only positionWS and meshNormals/normalsWS or so…

this should be fixed now. if you open the launcher it will update itself, then try to install the plugin again.

I am not able to fined this can you give some more information or a screenshot?

This part is inside the NullMesh node in the help patch:


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.