Gamma 2021.3.1 crashes

I dont know what happened but gamma crashes at startup on this screen without any message
gamma nightly 2021.4.0-0008 works perfect. Earlier this morning 2021.3 had worked


Possibly related (but unsolved)

Remote Desktop? Really?) I dont use any. Should I worry?

Try to reinstall, second option to disconnect usb devices, maybe a driver crash…

yes, RDP, really (as akward as it sounds). don’t have any other options for our uni as with RDP we can use our faculty authentication. VNC (my preffered option) is not a choice unfortunately.

@motzi My joke was about I don’t use RDP at all in any form — my PC in front of me. It’s disbled in settings. Who and why uses RDP on my computer?)

@yar check windows Event Viewer for more details of the crash.

@bjoern thanks, there it is:

Application: vvvv.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.NullReferenceException at VL.Lang.View.PatchEditor.Finder.SymbolFinderControl…ctor() at VL.HDE.PatchEditor.EditorControl.InitializeComponent() at VL.HDE.PatchEditor.EditorControl…ctor(VL.Model.VLSession, VL.HDE.Forms.FormManager) at VL.VLContext+UIContext.Initialize() at VL.VLContext+UIContext+<>c__DisplayClass9_0.b__0() at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object) at System.Threading.ThreadHelper.ThreadStart()

After 2021.3.2 Update still crashes with the same error


odd. the fact that you say the latest preview works but the stables not could be a hint though: please delete all your nugets from


and see if now you can start the stable again.

@joreg nope, it didn’t help
btw there is Nuget (2.7 KB)

mkay… two more global files that come into play during startup:


please first remove the settings.xml, try a start. if that doesn’t make a difference also remove the args.txt if you even have one.

@joreg removing of setting.xml helped!
file that cause my problem —> (761 Bytes)

Seems like a problem with a custom stylesheet that not found in Gamma lib folder but the setting is global

glad to hear, but can you elaborate on this please:

so you had a custom css specified but that file wasn’t actually there? what do you mean by “but the setting is global”?

stylesheets lays near the main application — lib\stylesheets
but if change setting in xml, new version that doesnt have this stylesheet by default link to the same xml. Seems like it’s what exactly cause the problem — lost file while parsing of HDE xml settings.

<SETTING name="Stylesheet">

perfect, ja, that explains. we’ll find a better way to catch this.

but also note that you can specify an absolute path to your css in order to share it between vvvversions.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.