FYI: DisplayLink driver kills x32 DX11

I got an ASUS MB168B USB3 DisplayLink screen for my laptop, and tested it first on my desktop system. Worked great, and it is actually a very cool way to get a second screen on a laptop - even plays 720p vids fullscreen at 30fps.

However, it turns out that the software needed to run it, “DisplayLink Core Software”, was causing 32 bit apps (like vvvv) to think my GTX770 graphics card on my desktop only supported DX 10.1, not DX11.

So if you have or get one of these screens, be warned this may happen. The symptom in vvvv x32 is the DX11 Quad throwing errors on the console and not working, and the DX11 Info node reporting Level_10_1. The windows program DxDiag will also report DTI 10.1 on the Display tab. But all will be fine with vvvv x64, and the 64 bit version of DxDiag will report DTI 11.

Just so’s ya know.

Please try the 7.5M0 drivers at - we believe this has been fixed, but would be interested to know if you still have problems.

Hellöle Mediadog,
say, did you incidentally try the remedy that danellis recommended? if so, did it help? I’m kind of interested in the little asus screen. But I do need my VVVV

Hey max, since I don’t use this screen on my desktop I haven’t tried the new drivers (the laptop I use it with is an older one without DX11 anyway). If I can get some time today I’ll give it a shot and report back.

Well, I tried to install the latest DisplayLink driver (7.5MO), but it complained that my USB3 drivers may not be compatible. I have the latest for my motherboard (ASUS P8Z77-V Deluxe) so I did not install it. Sorry, good luck!