FromSharedTexture (DX11) bug

If the texture output pin of this node is disconnected then reconnected, it loses output until the node is ‘reinitialised’. Is this a divide by 0 bug or similar?

Context - using FromSharedTexture to receive textures with spout.

yes same here…tried everything - even continously rendering to a quad - but as soon as you connect preview and disconnect it crashes…really annoying.

help would be highly appreciated

as far is i could see this happens either if the receiver node is initialized after the sender is already running or if node gets disconnected downstream.

i did a little fix due to first-frame initialization of the node which fixes the first behavoir for me
additionally i added an update pin which fixes the second behavior (as i call this periodically)

as iam not able to build the whole dx11 pack here i just compiled this in a separate dll for now.

see if that works for you too.


i. (1.5 MB)


Sorry for getting up an old post… as I seen you also use Spout…
I 've tried the new spout nodes that are bundled in new alphas, finding dx9 nodes work great. But DX11 spout modules from joreg’s github: (not merged yet with the master DX11 girlpower) don’t get to work cause of the FromSharedTexture (DX11.Texture.2d) node.

Tried milo’s dll and it worked with it… but having a memory leak each time a sender is restarted with a diferent pointer, always leaving the receiver active in this setup.
I’ve been testing leaks with spout developer and I think he managed to get it free from the Spout side. More information, and new demo sender/receiver here:

Any hints to get rid of this memory leak?? (happening both in GPUmemory and system RAM)