Flash Render Bug

Ive noticed in vvvvbeta_33beta10 - when i am using flash player 9 - that when I am working with my patch it somehow magically goes white. and says Movie is not loaded when i right-click.

When it was working just a moment before, it seems as if for some reason the flash renderer just unloads swf movies.

I have the following nodes in my patch

I am using the latest (vvvv33_beta11.1)
there are a few inconsistencies with the flash renderer:

Notice how in the attached Patch, I have managed to hide the flash from rendering in a seperate window, load a *.swf into it

  1. Right Click It to select Renderer(Flash) Node,
  2. Right-Click Renderer (Flash) Node and a white window pops up(where is swf??)

Notice: If you opened this patch up you will see your flash, now there is a grey box ontop of your flash in the gdi texture!

  1. Right-Click Renderer (Flash) Node again to hide window, the white box is still there??? :(

jarrads.v4p (4.0 kB)

confirmed. there seems to be some troubles with the current flash-renderer. will see…

still. while the renderer window is hidden you won’t get any fresh output on the gdi-texture. in your patch the renderer is not invisible but only has height=“0” (which you can only see when opening the patch in a text-editor).

the bug i found was that when opening the renderer-window (by rightclicking on the node) flash was not re-initialized and thus only showing a white quad (which was gray in the ex9-renderer because your quads color was set to gray). so when after opening the renderer-window you disable and reenable the flash-renderer you should see your file again.

I originally had the flash player showing, but at a tiny size - this is good for interactive swf’s

Thank-you for fixing :D

Humm - I too am having problems with the Flash renderer. In fact there are two:

  1. The Flash -> GDITexture -> Quad -> EX9 Renderer chain doesn’t work (even with the disable/enable trick above).
  2. The renderer doesn’t seen to cope very well with flash files that generate sound. On my machine the sound is mostly supressed, but will suddenly burst through in clicks. At least I would hope for either complete suppression or full playing of the sound. An audio feed out of the renderer would be even better.

I’ve attached my (very simple) patch and a flash file I was using to test in a zip.

Flash problems.zip (58.0 kB)

thanks for noting. i fixed the bug that would not let the flashmovie start when play=1 before a filename is chosen on the renderer. meanwhile setting play=0 and play=1 after having chosen the filename should play the flash file. even on the quad. it does so for me in your patch.

i see the problem with sounds and don’t have any idea where it comes from. even when my cpu is at ~18% the flash sound stutters as if there was to few cpu-cycles for it. when i use the mainloop node to lower vvvvs fps it gets better…hummm…

probably this is related to the sound problem. can you try what they suggest with “event sync” vs. “stream sync”

I’ve created a login now!

Thanks for the update. Like you if I slow the frame rate down the sound gets better, but still far from perfect!

The Flash appears in the flash renderer OK, but I still don’t get anything in the EX9 renderer after putting the output of the flash through GDITexture and Quad (see the patch from my previous post).

Where is the control for “event sync” vs “stream sync”? I can’t find it!

i am not into flash. according to the article i linked i thought the “event sync” vs “stream sync” is a setting you can chose inside flash.

if you dont see the flash output on a texture you should try opening a Renderer (TTY) before connecting from Renderer (Flash) to GDITexture and see if an error message appears in the tty.

what is your graphiccard? do you have its latest drivers?

Sorry didn’t notice the link before, now I understand! I don’t have access to the flash source so I can’t try for this file. To be honest I don’t really need the sound - I was just reporting the possible bug.

What I do want to try and get going is the flash -> texture.

I tried with a TTY open and didn’t get any error reports.

The graphics card is an Nvidia FX5200, and I just got a new set of drivers.

I guess the fact you ask the question means that it works on your machine?

right. it works on my ati firegl v5000. so i guess it is the fx5200 which i had other troubles with yet. try setting the flash renderers backbuffer width/height to values that are powers of two, like 256x256, 512x512 or even 512x256 and see if that does.

Thanks for the tip.

I tried it on my laptop (Intel integrated graphics) and the rendering worked fine.

Setting the backbuffer to 256x256 on the FX5200 got things working on the desktop as well.

By the way - with the backbuffer set to the non-working values there seemed to be some problem with the file load/save for the patch. Opening the saved patch didn’t even render in the flash window. Now that the backbuffer is set to something that works all seems well again.

ok. the backbuffersize thing on selected graphiccards and the sound problems will remain for now. the rest is fixed for versions >11.1