Filestream2 crashes at file-res change

Ive encountered a bug in filestream2 (which is nice btw ;):
If I change video to a different one with different resolution, filestream2 chrashes, shows funky patterns (memory stuff?) and V4 hangs up.

Which is in tech speak by g-spot:
both videos are H.264/MPEG-4 AVC

mp42: MP4 v2 [ISO 14496-14](ISO 14496-14)

  • mp41: MP4 v1 [ISO 14496-1:ch13](ISO 14496-1:ch13)
    Recommended Display Size: 844 x 988

change to second

mp42: MP4 v2 [ISO 14496-14](ISO 14496-14)

  • mp41: MP4 v1 [ISO 14496-1:ch13](ISO 14496-1:ch13)
    Recommended Display Size: 1688 x 988

I use ffd show (multiple instances enabled) and Haali media splitter.

Another strange behaviour is if I start two filestreams2 (was looking for a resolution workaround) everything is fine as long as I do not connect them to same string.spread input (splitting done by getslice). Because at a fresh start both renderer will show same video (one of both) instead of two different. If I connect a single string input to my second filestream2 this doesnt occur at start.

edit: Found a workaround: Instead of getslice, a switch at filename input and a switch at texture output is working - only filestream2 which is dedicated to small or big res is playing then. So, a hard switch between two filestream2 (having loaded my two resolutions at start) does the job.

Or is this a ffd-show issue?

filestream2 is still quite alpha, so your issues are probably not ffdshow related. thanks for that report, i’ll see what i can do about it.

similar problems.

filestream2 isn’t even connected to a videotexture. just choosing a videofile lets v4 crash and freeze.

funny enough is, i’m using the exact same subpatches in 2 similar projects with filestream2 and they work.

only difference, this project loads a lot of 3d geometry although the memory tells me there is still space.

what does filestream2 different to filestream ? i’d like to know to narrow down the problem…

haha…looks like its crashing when its NOT connected to a videotexture

found the cause…well somehow.

i used camera(softimage) in this patch, tty renderer talked something about converting this from version 2.1 and a missing link.

i won’t investigate this further but i removed every subpatch and tried to find the killer… since removing camera subpatch , loading something into filestream2 doesn’t freeze v4 anymore.

can you see some relation, joreg ?


here is a very simple patch to reproduce the v4 crash…

just choose the AVI to play with filestream2 …kabumm (396.3 kB)

ouright, seems i was able to fix u7s problem for beta>23. haven’t checked for franks yet…

kind of everything. for those interested, it is based on GMFBridge.

the problem seemed related to the fact that GMFBridge handles videos with and without audio differently. probably you could confirm that your demo-patch worked with the same clip if it had an audio channel. anyway with the fix both should work.

mmm, but why was it working fine without the camera subpatch ?

i’d have to guess that there was a memory corruption taking place that was randomly influenced by that patch…