Feedback loop ex9 texture error amd radeon


Maybe someone can help or has experienced the same problem with AMD Radeon GPUs

Any kind of FrameDelay using an EX9 Texture gives me an error after 10 to 50 seconds depending on the resolution. This happens with any feedback loop or Queue (EX9 Texture) - so basically anything that stores the texture for a frame or more.
When it happens the according node becomes red and any EX9 Renderers go black until I restart vvvv. Seems to be a problem with the buffer, but the memory generally looks fine before it happens.

The thing is: It only happens on my desktop PC with an AMD Radeon HD 7990 GPU. On my other machines with Nvidias I do not have this Problem.

The tty renderer sais either:

in 45beta32.1

  • [MainLoop.TMMainLoop.DoTimer: error occured in Graph.TMBasicNode.ResetCacheCB](MainLoop.TMMainLoop.DoTimer: error occured in Graph.TMBasicNode.ResetCacheCB): Access violation at address 00715FFB in module ‘vvvv.exe’

or in 45beta33.3:

  • [PrepareGraphCB of FrameDelay (EX9 Texture)](PrepareGraphCB of FrameDelay (EX9 Texture)): Access Violation at address 006EAF45 in module ‘vvvv.exe’

I had a similar problem a year ago. Back then it was the latest ati driver that caused the problem. It seems like the current drivers does not have this problem.

EDIT: I solved it by reverting to an older driver.

there is known problem

thanks for the answers

Well it does seem like a driver issue since all the different drivers provoke a slightly different error, but always caused by the same framedelay issue. I downgraded and upgraded and tried manual driver change and used the AMD interface…

but so far no luck :(

With the most current display driver it takes longer until I get an error but the driver and with it vvvv completely crashes

but there are still some version I did not try yet.

@ ggml: the error also occurs without any switch connected to the framedelay and it also appears if I just open a queue (EX9.Texture) and store more then one texture without any framedelay open.

oh, I also remember that back then I went down to beta31.2 or was it 30.2 to get it working

thanks sune! beta 30.2 seems to be working… but strange. Would be nice to know what the difference is.

might it be caused by vvvv defaulting to dx9ex since beta32?
you could try starting a recent v4 version with /dx9, if you don’t need texturesharing