Forum

Failing playing mjpeg with filestream (win7 64)

Hi! I have a little problem… I used to have mjpeg video samples working in vvvv, but since i’m on windows 7 64 they don’t work anymore, filestream1 or 2 gives the same: a black renderer.
However mjpeg videos are working fine in media player classic.
I use picvideo mjpeg codec 4.
Klite megacodec pack was installed before, with default settings.

I don’t know where it’s from, i heard windows 7 has a restrictive management of ffdshow filters (only microsoft’s ones would be used?) but nothing more.
Don’t know that much on codecs…

For the moment i’ve switched to indeo video codec 5.10 (which looks to work nice too) but if someone have any info on that mjpeg problem i’m interested…

so after installing 64 bit codec, you have to install 32 bits my case Mjpeg 3, like NOT primary mjpeg codec.
Then go to C:\Program Files \Common Files\Pegasus Imaging\ and replace file pvmjpg40.dll with pvmjpg30.dll from C:\Windows\SysWOW64\ don’t forget to rename it to pvmjpg40.dll. Done. Compressing plaing ok.

working fine! thanks a lot

I’ve had no problems, you installed the 32bit codec or the 64? vvvv I think will only work with the 32bit codec…

I had 64 bits… Now i uninstalled everything and only reinstalled version 4 in 32 bits and it’s working fine indeed… next time i’ll think twice before screaming! :)

regarding the ffdshow problem on windows7. yes …win7 initially uses its own mjepg codec instead of ffdshow.

but i managed to change that behavior using graphstudio.

expecting you have ffdshow already installed…

  1. start graphstudio as administrator like you need to start vvvv for the first time.

  2. choose option ‘insert filter’

  3. in this dialog look for the plain windows7 mjpeg codec and change its merit (merit button) to something like 'don’t use ’

  4. same dialog, find the ffdshow codec and change its merit to please use this frackin thing…

done