Export fails in gamma 5.3-52

We have a simple patch using ImGui, NetMQ and Stride. We also use a small CSharp project to define a struct that we send over the network.

During export I get the following error message:

Generating project files (this may take up to a few minutes)
Building projects
dotnet publish -c Release --self-contained false /clp:ErrorsOnly /nologo "C:\Users\seltz\Desktop\FieldParameterSimulator\Export\src\FieldParameterSimulator\FieldParameterSimulator.csproj"
Unable to build C:\Users\seltz\Desktop\FieldParameterSimulator\Export\src\FieldParameterSimulator\FieldParameterSimulator.csproj. Reason:
C:\Users\seltz\Desktop\FieldParameterSimulator\Export\src\FieldParameterSimulator\FieldParameterSimulator.vl.cs(40,17): error CS0234: The type or namespace name 'FieldParameters' does not exist in the namespace 'e8' (are you missing an assembly reference?) [C:\Users\seltz\Desktop\FieldParameterSimulator\Export\src\FieldParameterSimulator\FieldParameterSimulator.csproj]
C:\Users\seltz\Desktop\FieldParameterSimulator\Export\src\FieldParameterSimulator\FieldParameterSimulator.vl.cs(8,14): error CS0430: The extern alias 'e8' was not specified in a /reference option [C:\Users\seltz\Desktop\FieldParameterSimulator\Export\src\FieldParameterSimulator\FieldParameterSimulator.csproj]

There was a problem exporting your Application.
Please report the problem by clicking "Copy To Clipboard" to copy the above details to your clipboard and pasting it to us via forum or chat.

Thanks for fixing.

FieldParameterSimulator.zip (1.7 MB)

Thanks for the report and the little test project. Fixed in upcoming.


@Elias tried it with the latest preview and it does indeed work now :) Still not working using our own built version of vvvv, but we got a lot closer in figuring out what might be the issue.

Thanks for the quick fix!