Forum

Enums loose their data

hi there!
While working on the new Help patches for the Unicode Nodes, I noticed, that IOBox (Enum) loose their data when saving, closing and reopening a patch. That’s quite bad.

i don’t know if this is an old or a “new old” bug.
but i remember that i had this bug with beta3 or 4.

for sure one of the bugs that make vvvv beta forever.

not this time I hope. The new startup patch depends heavily on Enums.

The bug affects not only IOBox (Enum) but also all enum Pins!!!

I’ll post an example patch later.

attached is a demo patch.

bug seems to be new in the upcoming beta 11. With beta 10 I couldn’t reproduce the bug.

Off topic but also very annoying: the boxed renderers appear always in the upper left corner of the patch when the patch is saved, closed and loaded. You have to hide and re-box the renderer to get the render window in the renderer box.

enum_bug_beta11.v4p (5.9 kB)

nachtrag:
the enum bug has nothing to do with björns edits of the unicode nodes. bug happens also with older nodes like waveshaper.

After further testing, I’ve noticed that Enum pins don’t loose their setttings in a reproducable manner. But all IOBoxes (Enum) connected to a Enum Pin do.

In the patch file, the Enums are saved correctly. The messup happens OnOpen.

ah. very thanks.
identified the problem with ioboxes.

Enum pins don’t loose their setttings in a reproducable manner.
any patch for this problem?

I’ve tried to reproduce the bug with the enum pins for some time now, but it didn’t show up again (beta 10 and 11).

I think, the last time it happended, there was first an IOBox (Enum) connected to the pin and then I deleted the connection and after reload of the patch the enum pin lost the value it had from the deleted IOBox.
I’ll try some more and post a patch if I can reproduce the bug.

i found a patch with which i can reproduce the bug.

seems that this bug is already solved. i had a problem loading the new help patch for Glyphinfo. but after updating (Enumtypes) it doesn’t appear anymore. so it seems that this bug was only a temporarily internal bug which didn’t show up in an official release.

@gregsn: yes. it was only present in the upcoming beta11.

wakeup call!
IOBox (Enumerations) connected directly to an Enum pin don’t loose their data, but if they are themselves pins in a module, they do. they also make any other enumbox connected to that pin in the parent patch loose their values.

(try changing it in the attached patch, then save & reload to revert to original)

ioboxenumtest.zip (2.0 kB)