Forum

Elotouch integration

hi all,

i have a touchscreen (ELO) connected to the com port 1, but simply don’t get any data out of the touchscreen(elo)-node. the touchscreen generally works on my system, so i could solve my problem by simply using the mouse (global)-node, but what is then the touchscreen-node for?

thx for any hints,

schilcman

mhh strange. i connected an elotouch yesterday and it worked perfect…

have you set the “enable” inlet to 1?

Do you have allready installed a mousedriver emulation? i guess so, if you can use the mouse (global) node. if thats the case it could be, that access to the comport is blocked for the node… the touchscreen (elo) node communicates directly with the device and doenst need any driver…

try to deinstall the mousemulation driver, i think that this should help …

the node gives you also a nice z value (pressure) too,

thanks to you!!! the problem is solved.

mfg schilcman

ok, just another thing:

i get the appropriate touchscreen coordinates, but the z value thing doesn’t work. it seems as if pressure values aren’t recognized. that’s not very helpful concerning my project, because i need to define wether the touchpanel is in use or not.
any ideas?

lg, schilcman

what type of touchscreen (capacitive, ultrasonic, resistive etc.) do you have? see ELO Touchscreen Technology Choices - not all types support pressure…