Forum

Dynamic Plugin Nodebrowser

new(ly) cloned dynamic plugins don’t show up in the alphabetical list in the nodebrowser. can only find them via category.

reproduce: new v4 patch, clone template, search for it in the nodebrowser

1 Like

sorry for late. i’ve just tried to replicate this in b38.1 to no avail:

  • open b38.1
  • save patch
  • dblclick for nodebrowser -> clone c# template with name “foo”
  • dblclick for nodebrowser again -> type “foo” -> node shows up as expected

can you confirm this works now or are you doing something differently?

skip the part, where you save the empty patch.

just figured it’s not only dynamic plugins but also vl, modules, etc. doesn’t have to be newly created. drag n dropping some existing ‘externals’ on the unsaved patch behaves the same.
everything can be found in the category list.

seems like only tag view is factoring in the search paths when determining the visible node entries:

actually this even happens, if the patch is saved, as soon as the external file not located in a subdirectory of the directory, where the patch is saved:

ok, i can see now. i’m afraid though, we considered this lower priority.

specifically since with the upcoming b39 at least when cloning a template, they will now show up in the nodebrowser. you don’t even have to save the patch anymore before, because they now have a default save location.

so the problem is now reduced to externals you drag-drop into the patch from sources that are not yet known as searchpaths.

what’s the reason for hiding away nodes anyways?

the problem also occurs if you are working in a subpatch (saved somewhere else than the parent) clone a dynamic plugin in the subpatch, which will be created automatically in subpatchfolder/plugin and therefore not in the global searchpath, not visible to the parent patch (or any other patch)