DX9 to DX11 texture

am I doing it right?

I am not getting a texture through

from TTY:
00:01:07 : E_INVALIDARG: An invalid parameter was passed to the returning function (-2147024809) Handle: 3221229376 Format: A8R8G8B8


DX11toDX9texture.v4p (6.5 kB)

  1. the other way around DX9 >>> DX11 also not working
  2. here Alt+LeftClickDrag not working with tabbed DX11 Renderers

DX11convDX9texture.v4p (11.9 kB)

For first one, dx11 texture to dx9 is not supported (and to be honest I don’t plan to), if someone wants to write a node dealing with it you’re very welcomed.

For second one seems there’s range error, strangely I thought Joreg fixed it, seems it’s not ;) I’ll change my node so it gets IntPtr instead to avoid that, but dx9 side will also need to update.

@vux, i still think it is fixed. only the AsSharedTexture probably needs a fix as well as i pointed out here: https://github.com/mrvux/dx11-vvvv/pull/42

attached is a module that should go to the pack.

DX9ToDX11 (DX11.Texture 2d).v4p (3.4 kB)

hm, i’m experiencing problems with assharedtexture, too. it happens that there’s no pointer is coming out - thus forcing me to reload the node (e.g. via ALT+RClick)
perhaps we just need a refresh-pin for a non-automatic fix?

i try to investigate further and report my findings

AsShared should also need that, but here it’s sent from Info, and i saw there are still range errors.

I’ll just recheck

finally i also start messing around with that lovvvvely DX11-stuff…

currently lifting a quite heavy patch (4 videocams etc.) from DX9 to DX11.

i noticed a Memory leak within the module posted by joreg (have 6 instances in use…).

with level = 0 on the Info (EX9.Texture) the Shared Handle alternates each Frame (at least here).
Setting level to 1 after a few frames almost stops the leak; and hovering some output pins of the Info (EX9.Texture) seems to be finally very helpful…

your old kalle

p.s.: a modified version of the module is attached

DX9ToDX11 (DX11.Texture 2d).v4p (5.6 kB)


which parameters do i have to use in the dx9 renderer i.o. to get a valid output of the dx9todx11 node? so far my dx11 renderer stays black. (31.2_x68)

thanks a lot!

did you start vvvv with /dx9ex commandline?

grazie, my bad!

Hi Joreg,

My DX9toDX11 node output still get invalid with /dx9ex commandline. (33.7 x86).

start vvvv.exe /dx9ex /o “dx9-11Test.v4p”

Any help please !

Thanks a lot !

dx9-11Test.v4p (4.7 kB)

@lokishenback you no longer need to use that commandline in b33.7 as it is now the default. if it still doesn’t work for you i am afraid i am out of ideas. maybe try on a different computer/graphiccard? or even try the x64 version if possible?

Neither x86 nor x64 works for me.
I will try on a different computer/gpu later.

Thanks all the same.

I’m adding my question here because it’s also about DX9toDX11:

  • 1: Why can’t I connect HTMLTexture to DX9toDX11 directly? It says it’s not valid.
    I have to use a DX9Renderpass…

  • 2: Sometimes, I get a blinking Texture when hiding The DX9 Renderer (I don’t want the Renderer to be open in the Background) Seems to be some Synchronization Problem. Doesn’t help when setting Mainloop background and foreground to the same. I attatched the patch.

What I’m doing this HTML-DX11-thing for? I need a two-colored, two-font-styled Textblock. DX11-Text is not capable of that… :( (Although I love the new DX11-Text :) )

DX9 to DX11 Blinking Problem (22.7 kB)

ad 1) that is indeed a problem with all textures coming from vvvv-plugins. it is on our list.

ad 2) try connecting an Info (EX9.Texture) or Pipet (EX9.Texture) to the DX9Textures output as well, and connect an IOBox to one of their outputs. like this you should get the dx9-pipeline running without the need for a dx9-renderer to be visible.

Pipet works quite well, thanks, joreg! :)