Forum

DX9.texture buffer/queue glitch?

Hi,

I’ve just encountered a problem with both the queue and buffer (both for DX9.Texture) nodes; I don’t have a clue wether it’s an error in my patch or in the node, but I suspect the patch (of course ;)):

In the attached patch, they stop working (they don’t seem to insert new frames) whenever they are not selected and shown inside an inspektor window. I’ve tried with both the queue and the buffer, the patch contains only the buffer node, it can be easily replaced - the result stays the same.

Short explanation of the patch: I am using a rope node to draw inside a dx9-window that does not clear; upon releasing the mouse button, the texture output of that window is stored in a buffer and applied onto a quad that is rendered in the background (behind the next rope) of that same dx9-window (I want to save the resulting image of multiple strokes without accumulating an enormous amount of raw input coordinates). However, the buffer does not seem to insert any frames (even when told in a loud and clear 1) unless it is selected and viewed in an inspektor window.

Does anybody spot the reason for this incomprehensible behavior? I am honestly out of ideas.

drawtool_resizer.v4p (46.5 kB)

helo diki.

it seems you have discovered a rare bug.
how about this workaround: instead of the quad you take a Pillow (DX9) with its fadecolor set to an opaque white (note: default is white with alpha=0%). this way the pillow acts like a quad and obviously the pillow doesn’t have that troubles with the texturebuffers.

hi joreg,

thanks for your answer. I’ve tried replacing the quad with a pillow, but this patch also stops working as soon as I deselect either the pillow or the buffer. However, I’m now storing the drawing as a collection of coordinates, saves the trouble.