DX11 to DX9... again

Hi all

is it just me or did the possibility of sharing textures from DX11 to DX9 die? at least I can’t get it to work. I use the recipe from this thread: https://discourse.vvvv.org/t/12368


bump, anyone?

sharer.v4p works for me.
33.7 & 34.1

How about 34.2?

Also here sune, but several versions dont work for me…

@catweasel do you mean that it is working for you or not?

No can get Dx11 sharing between instances and itself but no dx9-11, I think dx9-dx9 worked too…

The patch posted by @mediadog works for me. The Preview doesn’t even have to be connected and/or visible to make it run smoothly just “lying there” is sufficient. Using Renderer (DX11 TempTarget) instead of MRT also works.
Tested in fullscreen and windowed mode on main and secondary screen.

MacBook Pro / NVidia GForce GT 750 M, Windows 8.1 Pro x64, 45beta34.2x64

No luck getting the sharer patch to work on my system now…

Trying to figure out what changed since I used it last time, i have used it on this system successfully as late as in august.

my system is: Dell M3800, win10 x64 and I have tried with beta34.2 both x64 and 32 as well as with and without /dx11mode:nvidia also with alpha34.102x64 all same non working result.

any ideas on what else to try?

EDIT: I think it might have something to do with it having a quadro GPU (K1100M) but not sure.

Here is what TTY says when starting the Sharer patch, perhaps it can enlighten someone

SharerDX11toDX9log.txt (61.4 kB)

@Sunep I notice your display is quad HD - could this be a texture size limit you’re seeing? Try setting an explicit size in the DX11 and/or DX9 renderers to something small and see if that works. I know when using DX9 textures I seem to run into arbitrary limits that vary by system when using texture queues and the like.

@mediadog I do set the renderers at lower res, I am using the sharer example, I think the renderers there are 400 by 300

The sharer.v4p file does NOT work for me on 34.2 x86 on Win7 and a laptop with Intel HD 4000. But if I change the format in the SharedTexture node from A16R16G16B16 to A16R16G16B16F so it matches how the DX11 renderer is set (and how I have it in the sharer-1.v4p patch I posted), it does work.

So make sure your DX9 texture format matches the DX11 being generated.

Interestingly, if I then change it back, vvvv crashes!

hmm. Sorry guys, I guess this was one of the cases of… #windowshastoomuchstuffinstalledandgotconfusedandreinstallingwindowsfixedit

fresh windows = functioning texturesharing

Here I am again, reviving this thread, it has now happened again, just over a month after I reinstalled windows.

any ideas what could interfere with the DX11->DX9 sharing… or actually sharing at all?

I am going through what I have installed lately, since it has happened within the past 2 weeks or so, but my memory doesn’t serve me well so I am fumbling around a bit, uninstalling stuff.