Forum

DX11 to DX9 Again Again win update conflict?

early in january this year I reinstalled windows 10 on my machine, I did it after having struggled getting texture sharing working.

I use this to test if it is working: https://vvvv.org/sites/default/files/user-files/sharer-1.v4p

I tested ot at regular intervals after the reinstall and it worked nicely. but now it doesn’t work any more, I tried figuring out why and uninstallaed lots of things but nothing worked.

Now I have installed my machine from scratch, format of SSD and still no luck, fresh downloaded version of vvvv and DX11, runnning with the /dx11mode:nvidia parameter.

it is 2 to 3 weeks ago I tested it last time and back then it worked, so now I am suspecting that it is a windows update causing it.

am I alone or can some of you confirm this with a win10 64bit machine with all the latest updates?

what to do, I can’t keep wiping my machine, that is a bit tedious in the long run.

Sune

EDIT: TTY has this suspicious line coming out:

00:00:16     : E_INVALIDARG: An invalid parameter was passed to the returning function (-2147024809) Handle: 1073745282 Format: A16B16G16R16F

https://discourse.vvvv.org/t/13272

I don’t think it is related, I am on x64 and the thread is specifically about x32

and I tried on a different machine with no issues with all the recent windows updates, I am beginning to suspect it being my GPU drivers, will investigate into those.

soo weird, for the first time I have experienced that the optimus settings in the nvidia control panel worked.

I assigned the discrete GPU to vvvv and it works.

weird to see that optimus settings for the first time behave as expected.

Yeah. That thread says that x64, at the time, didn’t get fixed.