Forum

DX11 renderer texture out to wrong resolution

Hi guys, I had used DX11 renderer texture out to render a texture in order to make an effect with another one. But when I stretched the window into smaller size the output resolution also becomes small. I tried way like use the renderer(Temptarget)but doesn’t fit into 3D geometry. how can i solve it

Better is to use the MRT Renderer and set its internal resolution

Try a renderer temp target and set you resoltion manually, make sure you set the depth buffer and attach any transforms the other renderer has, and it should work. The temp target should replace the other renderer.

The MRT renderer and temp target is useful when deal with just textures layers but can’t see 3D geometries layers. However I used SetRenderer Module seems solved it. There’s DX11 version on it.

You need the group you are wanting to see in 3d, connected into the renderer temptarget layer input (and the camera transforms), if you come out of the renders output pin, you have already rendered the content to a texture at the resolution of that renderer.

I don’t know how but I reconnected the group output pin to fullscreenquad it’s working out. Thankyou guys

1 Like

The mistake I made was I didn’t connect my camera node and set right view to the new renderer

1 Like