Forum

Dx11.particles geometry emitter: particle count higher than geometry point count


#1

hi all,

@tmp, @antokhio

I am a little confused… my model has 166.080 points = 327.930 polygons.
Fed into info(geometry spectral) outputs a vertexcount of 983.790.

Shouldn’t i get 3 times (xyz) the original pointcount = 498.240 ?

Thanks


#2

Do you use the latest version of the particles pack?
Please provide a minimal example patch.


#3

hi!

yes, I use particles 1.0.6 x64.
I cut a part of my mesh, c4d says 68.366 points / 134.313 polygons

cmn.7z (2.5 MB)


#4

I can confirm the output 402939 indices. But using the Info( Assimp Mesh ) node gives the same result.
Perhaps a wrong export option? You could test that by exporting only one polygon and check the dae file.


#5

I exported a box as collada and obj… the files themselves look good - each of them contains just 8 vertices. info(geometry spectral) still finds 36 vertices. When I emit my geometry with the correct vertexcount I just see a part of my mesh - with 4 times of the original vertexcount it emits the whole geometry.

I tried emitting a box (dx11.geometry) with the geometry emitter… one box with 8 vertices results in this. it looks like 6 quads emitted along their normals…

emitter

maybe @antokhio could shed some light onto this :)


#6

Its pretty normal. It means when you export your mesh, the vertices are not “welded” (thats what its called in Rhino). That means each polygon writes its vertices, but no re-use of vertices is done. So adjacent polygons don’t use the same vertices, but you just get vertices that are in the same position. There should be an option in Blender too. Can’t find the correct term for this, but I know .obj supports both types.

edit: okay, just saw your exported file did contain only the correct number of vertices. Strange.


#7

Well it’s normal for you, try topology with point list setting


#8

Hi,

tried, but changing topology before geometry buffer does nothing for me :/ still, I don’t know why there are much more particles in the system than points on my model.

I would like to understand why the vertexCount from the geometry node is so large, and why the geometry emitter just works correctly with this large count.

callmenames.v4p (33.2 KB)


#9

This because of how indexed geometry works, for instance quad you have only 4 vertices, but you will need 6 indices (two triangles) so in the end your vertex count gonna be 6…
In the moment indexed geometry passed from CPU to GPU it gonna be decomposed to one large array or buffer and total amount of points will be amount indices needed to create all the triangles…

@schlonzo i think this approach is more what you want…
callmenames1.zip (7.4 KB)


#10

xxxx

thank you very much for your time!
all of you, guys