Dual graphiccard setup out of sync

this is just for the record. don’t try to use two graphiccards in one machine to render one scene with fast animation. no genlock results in this


Is it “just” two graphiccards or a Nvidia Surround setup?

Are they identical monitors?
You could render to a texture and then delay it a frame maybe??

just two graphiccards.

and no, framedelay won’t help, its out of sync, not delayed. frequency changes over time. this is tested thouroughly with 3 pc and different nvidia cards.

in the video there are obviously different monitors, we tested with identical monitors too. doesnt matter.

Confirmed on 2 ATI’s.
Thats very worrying.
Attached patch is an lfo, a quad with 2 renderers, fullscreen and they’re frames apart.
Eeek, this could be a spanner in the works for my current job!

sync error! (3.1 kB)

Try setting presentation interval to Immediate for one of them, its seems to fix it for me I think.

but immediate turns off vertical sync and produces tearing…or am i wrong ? i tried this too and sync was good but tearing looked horrible

i’d argue that immediate-mode (while of course not useable due to tearing) at least shows that the problem is only caused by a non-existing genlock between the cards.

i am quite certain a software-genlock could be achieved by using nvidias/amds or the powerstrip api to adapt monitors refresh rates dynamically. anyone?

@joreg the thing is the difference looks too big to be genlock, genlock suggests that the frames are 1 or 2 frames apart, in my test I had the screens separated by 1/2 second, ie the bar on one was half way down the screen the other was at the bottom, it looked like the patches were running off different lfo’s!

hm…but in your 1/2s off demo…if you set to “immediate present” it was in sync also. right?

with genlock there would be no frames apart at all. thats the idea. why you experience 1/2s off i cannot explain…maybe in sync mode graphic-cards can also decide to buffer some frames!?