Forum

Divided by zero exception in DX11 node


#1

I keep getting an error in the TTY renderer from one of the DX11 nodes. Not really sure what is happening but this is the error:

Stacktrace:
at VVVV.PluginInterfaces.V2.Spread`1.get_Item(Int32 index)
at VVVV.DX11.Nodes.Renderers.Graphics.DX11VolumeRendererNode.Update(IPluginIO pin, DX11RenderContext context)
at VVVV.DX11.Nodes.Renderers.Graphics.DX11VolumeRendererNode.Render(DX11RenderContext context)
at VVVV.DX11.Lib.RenderGraph.DX11DeviceRenderer.ProcessNode(DX11Node node)

04:39:39 ERR : System.DivideByZeroException in VVVV.PluginInterfaces: Attempted to divide by zero.

It is logged a few times per second and also makes “ML?” blink constantly in the Perf Meter.

I am using 32.1 64bit with the latest DX11 pack release (05.12.13) and all this is happening while the rendering is working fine.


#2

Nothing on this? @vux do you know whats happening with this error? I still keep getting it and its rendering the debug TTY useless, because its logging this error non-stop many times a second.

I am using mre.mdmod 2.1 to render.

Thanks for any help.


#3

Well without a patch that’s not gonna e so easy to guess ;)


#4

And please, issues to be reported here :

So I can reasonably track things


#5

Thank you @vux for your reply. I will send you a personal message with a dropbox link to the patch or via skype if possible. I dont really want to post it publicly (yet), as a lot of work has gone into it and it is really large.

Even more strangely the TTY Renderer actually keeps logging the error even if it is a) disabled and b) log errors is set to 0. It is greyed out but I can still see the errors being logged seemingly in every frame. Very strange indeed.


#6

Ok, I really have no clue whats going on. On one pc (retina MBP) it is logging the error and massively slowing everything down, while on another PC (windows8 PC, but much older than the MBP) it seems to not slow down performance at all. Also on this PC the TTY renderer stops logging if log errors is set to 0 or disabled, but on the other it doesnt. Its exactly the same patch and vvvv folder, both synced via dropbox.

WTF!?


#7

This got solved by @vux via skype. Thanks again! There was a switch needed for cases where there is no texture supplied in one of the nodes inside MREmdmod2.


#8

@:seltzdesign Hi, I am having the same problem with ml sign on perf meter and the same error message on tty renderer. Could you please explain a bit how you resolved this problem with :vux? Did you need to download a new patch from the github or was there a hidden switch inside the MRE node?


#9

Hello @youngjae. Hmm, I could have a look, but can’t seem to locate the skype conversation right now.

I seem to remember that if you go inside the render node, you will eventually find somewhere there is an NULL produced in the output somewhere (the O with a line through it). Just follow it up till you get to a node that outputs it. Like mentioned above its when there is no texture supplied that it produces it. So you can just put in a switch before it, which switches to 0 if there is no texture.

So its not a hidden switch, its just that there is no switch, where there should be. You can put it in yourself.

Alternatively you can just try to provide a texture where it should and see if it helps.

If you are still stuck I can try to dig out the patch and see what I did.


#10

don’t worry guys revamped emeshe is on its way now to a contribution. at least in march because of node festival