Disable Depth Clip per object in DX11

Hi there

I’m trying to turn off depth clipping for one of my objects in the scene.
Specifically i don’t want it to depth test against itself

The appropriate option seems to be:

“Enable Depth Clip”. But that has no effect (the renderer’s depth buffer is on, and i’m trying to turn the rasterizer’s depth clip option off for that one Layer).

Has anybody else encountered this?

What i’m aiming for is level 1 of the following:

Level 1

Object ignores depth buffer

Level 2

  • Object draws reading depth buffer from previous draw operations in the frame
  • Object does not write to depth buffer (and therefore does not read its own buffer writes)

Level 3

  • Object reads from depth buffer
  • Object keeps a temporary depth buffer
  • Object draws against that temporary depth buffer whilst writing to a new depth buffer which it does not read from
  • Renderer continues with new depth buffer

(p.s. - love the new forums! especially copy/paste images)

depth buffer test.v4p (8.4 KB)

here’s an example patch highlighting the issue

we’d expect the depth fighting to disappear when the depth clip is disabled

thanks to @sebl found a solution using the DepthStencil node which operates correctly

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.