Forum

DirectX Renderer Problems with with Matrox G550 Low Profile

Hi vvvvpros,
as a vvvv-rookie I need your help. I had a patch (playing a video without sound) running fine with a ATI X600 dualhead graphic-card. Know, for certain reasons I needed to change the pc and got a videoadapter Matrox G550 Dualhead Low Profile PCI (halbe Bauhöhe, Desktop-PC). The same patch is not working anymore. First I found out the newest G550 driver is not working in vvvvbeta11.1 since there were a lot of (nil) in the renderers(ex9) pins. The second newest driver seems to be fine, the pins of the renderer look fine.
Exactly the same videocodecs are installed as before with the X600.
Could anyone go through the logfile (TTY renderer) and explain to me what went wrong? Is the G550 not supported in vvvv?

Even loading the granularvideo-patch from Girlpower gives me the following errormeldung (with the G550, with the ATI X600 I had no problems, same patch). See below.

Thank you in advance for any advice.
Alessandro

< — output tty renderer of videogranular.v4p —>

Everything you know is wrong
physical : in use= 50, total = 261616 kb, avail = 128412 kb
virtual : in use= 2, total = 2097024 kb, avail = 2054528 kb
paging : in use= 17, total = 633092 kb, avail = 525088 kb

00:00:00 - : Hid (Human Interface Devices) DeviceController - OnDeviceChange
00:00:00 * : Direct3D initialized.
00:00:00 - : enumerating game devices
00:00:00 ERR : io.dll not found
00:00:01 - : mirror texture addressing mode is not supported by your graphics card.
00:00:01 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:00:01 - : mirror texture addressing mode is not supported by your graphics card.
00:00:01 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:00:01 - : mirror texture addressing mode is not supported by your graphics card.
00:00:01 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:00:01 - : mirror texture addressing mode is not supported by your graphics card.
00:00:01 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:00:01 - : mirror texture addressing mode is not supported by your graphics card.
00:00:01 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:00:01 - : mirror texture addressing mode is not supported by your graphics card.
00:00:01 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:00:01 - : mirror texture addressing mode is not supported by your graphics card.
00:00:01 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:00:01 - : mirror texture addressing mode is not supported by your graphics card.
00:00:01 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:00:01 * : a resource couldn’t be created because of the following reasons:

You tried to create a texture with width 0 and height 0. However …
Device conditionally supports the use of 2-D textures with dimensions that are not powers of two. The following criteria have to be met:

  • The texture addressing mode for the texture stage is set to D3DTADDRESS_CLAMP.
  • Texture wrapping for the texture stage is disabled (D3DRS_WRAPn set to 0).
  • Mipmapping is not in use (use magnification filter only).
  • Texture formats must not be D3DFMT_DXT1 through D3DFMT_DXT5.

00:00:01 * : a resource couldn’t be created because of the following reasons:

You tried to create a texture with width 0 and height 0. However …
Device conditionally supports the use of 2-D textures with dimensions that are not powers of two. The following criteria have to be met:

  • The texture addressing mode for the texture stage is set to D3DTADDRESS_CLAMP.
  • Texture wrapping for the texture stage is disabled (D3DRS_WRAPn set to 0).
  • Mipmapping is not in use (use magnification filter only).
  • Texture formats must not be D3DFMT_DXT1 through D3DFMT_DXT5.

00:00:01 : Adding node to filtergraph: VideoTexture (EX9.Texture VMR9)
00:00:01 : VideoTexture (EX9.Texture VMR9).Video --> Video Mixing Renderer 9.VMR Input0
00:00:01 : Connecting from: FileStream (DShow9).Video to: VideoTexture (EX9.Texture VMR9).Video
00:00:01 * : nil pins can not be connected in directshow graph
00:00:01 * : couldn’t find/create node (ID: 1) in patch root.v4p ////. deleting action.
00:00:01 : Adding node to filtergraph: FileStream (DShow9)
00:00:01 : FileStream (DShow9).Audio --> C:\Programme2\VideoSync\clock.avi.Output
00:00:01 : FileStream (DShow9).Midi --> C:\Programme2\VideoSync\clock.avi.Output
00:00:01 : FileStream (DShow9).Video --> C:\Programme2\VideoSync\clock.avi.Output
00:00:01 : Connecting from: FileStream (DShow9).Video to: VideoTexture (EX9.Texture VMR9).Video
00:00:01 : ds connect from: Output to: VMR Input0
00:00:02 * : Texture [Width: 512, Height: 512, Format: X8R8G8B8, Mip Map Count: 1](Width: 512, Height: 512, Format: X8R8G8B8, Mip Map Count: 1) couldn’t be created because of unknown reasons.
00:00:02 * : Texture [Width: 512, Height: 512, Format: X8R8G8B8, Mip Map Count: 1](Width: 512, Height: 512, Format: X8R8G8B8, Mip Map Count: 1) couldn’t be created because of unknown reasons.
00:00:02 : Das Format einiger Daten in diesem Video wird nicht unterstützt.
00:00:02 : FileStream (DShow9).Audio --> AVI Splitter.01) Microsoft Waveform: 12TONEt2.WAV
00:00:02 : FileStream (DShow9).Video --> Color Space Converter.XForm Out
00:00:02 * : Texture [Width: 512, Height: 512, Format: X8R8G8B8, Mip Map Count: 1](Width: 512, Height: 512, Format: X8R8G8B8, Mip Map Count: 1) couldn’t be created because of unknown reasons.
00:00:02 * : can’t draw whole geometry at once. for example you have spreaded a texture / renderstate / texturestate… switching to slicewise rendering.
00:00:02 : Removing Filter: Video Mixing Renderer 9
00:00:02 : Removing Filter: Color Space Converter
00:00:02 : Removing Filter: AVI Decompressor
00:00:02 : Removing Filter: AVI Splitter
00:00:02 : Removing node: Video Mixing Renderer 9 from filtergraph
00:00:02 : FileStream (DShow9).Audio --> C:\Programme2\VideoSync\clock.avi.Output
00:00:02 : FileStream (DShow9).Midi --> C:\Programme2\VideoSync\clock.avi.Output
00:00:02 : FileStream (DShow9).Video --> C:\Programme2\VideoSync\clock.avi.Output
00:00:02 : Adding node to filtergraph: FileStream (DShow9)
00:00:02 : FileStream (DShow9).Audio --> C:\Programme2\VideoSync\clock.avi.Output
00:00:02 : FileStream (DShow9).Midi --> C:\Programme2\VideoSync\clock.avi.Output
00:00:02 : FileStream (DShow9).Video --> C:\Programme2\VideoSync\clock.avi.Output
00:00:02 : Adding node to filtergraph: VideoTexture (EX9.Texture VMR9)
00:00:02 : Connecting from: FileStream (DShow9).Video to: VideoTexture (EX9.Texture VMR9).Video
00:00:02 : ds connect from: Output to: VMR Input0
00:00:02 * : Texture [Width: 512, Height: 512, Format: X8R8G8B8, Mip Map Count: 1](Width: 512, Height: 512, Format: X8R8G8B8, Mip Map Count: 1) couldn’t be created because of unknown reasons.
00:00:02 * : Texture [Width: 512, Height: 512, Format: X8R8G8B8, Mip Map Count: 1](Width: 512, Height: 512, Format: X8R8G8B8, Mip Map Count: 1) couldn’t be created because of unknown reasons.
00:00:02 : Das Format einiger Daten in diesem Video wird nicht unterstützt.
00:00:02 : FileStream (DShow9).Audio --> AVI Splitter.01) Microsoft Waveform: 12TONEt2.WAV
00:00:02 : FileStream (DShow9).Video --> Color Space Converter.XForm Out
00:00:02 * : Texture [Width: 512, Height: 512, Format: X8R8G8B8, Mip Map Count: 1](Width: 512, Height: 512, Format: X8R8G8B8, Mip Map Count: 1) couldn’t be created because of unknown reasons.
<— endless loop of the last two lines —>

huh. there is a lot going wrong…

lets see:

00:00:01 - : mirror texture addressing mode is not supported by your graphics card.

this one should actually be handled within vvvv but obviously is not. the g550 doesnt support texture mirroring. you can manually change that via the Address (EX9.Samplerstate) node connected to all rendering primitives (ie. quads, grids…). when the node is connected the default is texture wrapping. i think that should do. if not try setting it to clamp.

00:00:01 - : level of detail (LOD) bias adjustments are not supported by your graphics card.

i am not sure about that one. probably it is the Filter (EX9.Samplerstate) node set to linear mipmap filtering. try setting that to none.

You tried to create a texture with width 0 and height 0. However …

should also be handled by ffff automatically. width/height set to 0 should autoscale the textures to good values. here it obviously doesnt and you should set the size manually to a power of two (ie. …64, 128, 512,…) for width and height manually. select the filetexture node with hrn.inspektor and change the values for width/height appropriately.

try those and then we whats left of the errors.
probably you should also start to build the patch new to better isolate the problems. before you start open a (Renderer (TTY) )) to see all problems arise immediately.

hi joreg.
thank you for the fast answer. i did what you suggested to doing (though there is no file-texture node in this patch, in videotexture i can’t set the width and height manually).
when i start with a new simple patch it is not working for the moment. i still get lots of errors. as my timeschedule is very tight i will get the other graphic-adapters (ATI) again and continue with my work (knowing that this is not the real solution to my problem)…

if you wish i can post the patch and the error.log (tty) later on this week.

regards
alessandro

hm. is it really only a videotexture? there you could try to set the TextureSizeMode to Pow2Stretched.

i can have a look at your patch but dont have a g550 at hand so probably won’t see those problems.

i would rather recommend starting simple, like showing a filetexture on a quad (nothing else in the patch) and post the ttys output here.

next show a videotexture on a quad and post the ttys output here.

scheisse!! i posted a long and detailed reply but it got lost some where in the net. aaarg!
step to step i did what you said but had more or less all the same error as above. adding the address(ex9.sampler.state) node i had some schutzverletzungen(?) in vvvv.exe at address xyxyxy.
i can show a image with filetexture, the video (filestream, videotexture, quad, address, renderers (tty & ex9) and nothing else) won’t show up, even not in nonpow2 (reminds me to 1942 arcadegame) mode.

thank you, but i really i don’t feel like posting all this again.
alessandro

edit:

the movies is 1280 x 640 px, for dualhead in span mode, works with ati x600 with kkontrolzzenterr

in notepad i found this:

00:23:05 ERR : Das System kann die angegebene Datei nicht finden.

00:23:05 : Adding node to filtergraph: FileStream (DShow9)
00:23:18 : Adding node to filtergraph: FileStream (DShow9)
00:23:18 : FileStream (DShow9).Audio --> C:\Dokumente und Einstellungen\vvvv_2\Desktop\bildschirm3+4_1280x512.avi.Output
00:23:18 : FileStream (DShow9).Midi --> C:\Dokumente und Einstellungen\vvvv_2\Desktop\bildschirm3+4_1280x512.avi.Output
00:23:18 : FileStream (DShow9).Video --> C:\Dokumente und Einstellungen\vvvv_2\Desktop\bildschirm3+4_1280x512.avi.Output
00:24:53 : Adding node to filtergraph: FileStream (DShow9)
00:24:53 : FileStream (DShow9).Audio --> C:\Dokumente und Einstellungen\vvvv_2\Desktop\bildschirm3+4_1280x512.avi.Output
00:24:53 : FileStream (DShow9).Midi --> C:\Dokumente und Einstellungen\vvvv_2\Desktop\bildschirm3+4_1280x512.avi.Output
00:24:53 : FileStream (DShow9).Video --> C:\Dokumente und Einstellungen\vvvv_2\Desktop\bildschirm3+4_1280x512.avi.Output
00:27:29 - : mirror texture addressing mode is not supported by your graphics card.
00:27:29 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:27:29 - : mirror texture addressing mode is not supported by your graphics card.
00:27:29 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:27:29 - : mirror texture addressing mode is not supported by your graphics card.
00:27:29 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:27:29 - : mirror texture addressing mode is not supported by your graphics card.
00:27:29 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:27:29 - : mirror texture addressing mode is not supported by your graphics card.
00:27:29 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:27:29 - : mirror texture addressing mode is not supported by your graphics card.
00:27:29 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:27:29 - : mirror texture addressing mode is not supported by your graphics card.
00:27:29 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:27:29 - : mirror texture addressing mode is not supported by your graphics card.
00:27:29 - : level of detail (LOD) bias adjustments are not supported by your graphics card.
00:28:56 * : a resource couldn’t be created because of the following reasons:

You tried to create a texture with width 0 and height 0. However …
Device conditionally supports the use of 2-D textures with dimensions that are not powers of two. The following criteria have to be met:

  • The texture addressing mode for the texture stage is set to D3DTADDRESS_CLAMP.
  • Texture wrapping for the texture stage is disabled (D3DRS_WRAPn set to 0).
  • Mipmapping is not in use (use magnification filter only).
  • Texture formats must not be D3DFMT_DXT1 through D3DFMT_DXT5.

00:28:56 * : a resource couldn’t be created because of the following reasons:

You tried to create a texture with width 0 and height 0. However …
Device conditionally supports the use of 2-D textures with dimensions that are not powers of two. The following criteria have to be met:

  • The texture addressing mode for the texture stage is set to D3DTADDRESS_CLAMP.
  • Texture wrapping for the texture stage is disabled (D3DRS_WRAPn set to 0).
  • Mipmapping is not in use (use magnification filter only).
  • Texture formats must not be D3DFMT_DXT1 through D3DFMT_DXT5.

00:28:56 : Adding node to filtergraph: VideoTexture (EX9.Texture VMR9)
00:28:56 : VideoTexture (EX9.Texture VMR9).Video --> Video Mixing Renderer 9.VMR Input0
00:28:56 : Connecting from: FileStream (DShow9).Video to: VideoTexture (EX9.Texture VMR9).Video
00:28:56 : ds connect from: Output to: VMR Input0
00:28:56 * : Texture [Width: 2048, Height: 512, Format: X8R8G8B8, Mip Map Count: 1](Width: 2048, Height: 512, Format: X8R8G8B8, Mip Map Count: 1) couldn’t be created because of unknown reasons.
00:28:56 * : Texture [Width: 2048, Height: 512, Format: X8R8G8B8, Mip Map Count: 1](Width: 2048, Height: 512, Format: X8R8G8B8, Mip Map Count: 1) couldn’t be created because of unknown reasons.
00:28:56 : Removing Filter: Video Mixing Renderer 9
00:28:56 : Removing Filter: Color Space Converter
00:28:56 : Removing Filter: AVI Splitter
00:28:56 : Removing node: Video Mixing Renderer 9 from filtergraph
00:28:56 : Adding node to filtergraph: FileStream (DShow9)
00:28:56 : FileStream (DShow9).Audio --> C:\Dokumente und Einstellungen\vvvv_2\Desktop\bildschirm3+4_1280x512.avi.Output
00:28:56 : FileStream (DShow9).Midi --> C:\Dokumente und Einstellungen\vvvv_2\Desktop\bildschirm3+4_1280x512.avi.Output
00:28:56 : FileStream (DShow9).Video --> C:\Dokumente und Einstellungen\vvvv_2\Desktop\bildschirm3+4_1280x512.avi.Output
00:28:56 : Adding node to filtergraph: VideoTexture (EX9.Texture VMR9)
00:28:56 : Connecting from: FileStream (DShow9).Video to: VideoTexture (EX9.Texture VMR9).Video
00:28:56 : ds connect from: Output to: VMR Input0
00:28:56 * : Texture [Width: 2048, Height: 512, Format: X8R8G8B8, Mip Map Count: 1](Width: 2048, Height: 512, Format: X8R8G8B8, Mip Map Count: 1) couldn’t be created because of unknown reasons.
00:28:56 * : Texture [Width: 2048, Height: 512, Format: X8R8G8B8, Mip Map Count: 1](Width: 2048, Height: 512, Format: X8R8G8B8, Mip Map Count: 1) couldn’t be created because of unknown reasons.
00:28:56 : FileStream (DShow9).Video --> Color Space Converter.XForm Out

scheisse
this happened to me more than once. i try hard to get into the habit of pressing Ctrl+C to copy my edits into the clipboard each time before pressing Post.

hm. the address-node-schutzverletzungs-shit is blöd and hard to debug on our side without the g550.

when it says:

00:28:56 * : Texture Width: 2048, Height: 512, Format: X8R8G8B8, >>Mip Map Count: 1 couldn’t be created because of unknown reasons.
this could be due to lack of videomemory. have you tried playing a smaller video? you see that when playing a 1280x512 video in fact vvvv needs two textures of 2048x512 interneally (when forced to power2streched, which seems to be required by your card).

hi joreg,
yes i’ve tried with the in windows included clock.avi which is 321x321 pixel, filesize of 81kb. same problem. videomemory is 32mb. my notebook has got 32mb too and plays the file/patch, it’s a ati7500. i see if i can send you one of those stupid cards (g550 lp), i depends of how much i have to pay for it. would it be helpful for the development of vvvv?

nkay. now its really hard without the card. if you really need to use the card i’d need to put my hands on the card. i only have a motherboard with pci-express though around. will the g550 fit in there?

hi joreg,
no the card has got a agp-interface. i tested the same patch with a g550 (non low-profile) pci graphic-adapter - same errors. looks like the matrox g550 isn’t capable of playing videos in vvvv. args.txt (beta11.1) works fine indeed.

grüsse from cheeseland
alessandro