Forum

Depthbuffer to D32F_LOCKABLE


#1

Hi all!

Playing with depthbuffer options I found that setting it to D32F and switching to fullscreen, if I set AA to anything else than “None”, screen gets black.
Sometimes, as here,

it draws images from previous session of vvvv (as we have the flower texture from girlpower), even if it’s shut down with shift+alt+f4, and other 3D applications, even from Ubuntu partition (since we’ve got here some SuperTuxKart characters). PC wasn’t shut down, but simply restarted from Ubuntu to WinXP.

Deleting renderer and creating a new one solves all the issues.

Here’s what TTY renderer says:

00:02:06 - : Texture (Width: 1, Height: 1, Format: X8R8G8B8, Mip Map Count: 1) loaded in 0.000 seconds.

00:02:06 - : custom settings loaded in 0.021 seconds.

00:02:06 - : custom settings loaded in 0.016 seconds.

00:02:14 - : Texture (Width: 1, Height: 1, Format: X8R8G8B8, Mip Map Count: 1) loaded in 0.000 seconds.

00:02:14 - : custom settings loaded in 0.020 seconds.

00:02:18 - : Box (EX9.Geometry).Mesh (0) loaded in 0.001 seconds.

00:02:39 - : Texture (Width: 1, Height: 1, Format: X8R8G8B8, Mip Map Count: 1) loaded in 0.001 seconds.

00:02:39 - : custom settings loaded in 0.025 seconds.

00:02:43 - : Texture (Width: 1, Height: 1, Format: X8R8G8B8, Mip Map Count: 1) loaded in 0.001 seconds.

00:02:43 - : custom settings loaded in 0.022 seconds.

00:02:47 * : Cannot reset device. Try different parameters!

00:02:47 - : Texture (Width: 1, Height: 1, Format: X8R8G8B8, Mip Map Count: 1) loaded in 0.000 seconds.

00:02:47 - : [ custom settings ]( custom settings ) loaded in 0.026 seconds.

WinXP + GeForce9600GT (with latest working drivers).

Just to report in case is of some use (since D16 and D24 are enough to satisfy all my needs)

Bye.

fullscreencrash_2.v4p (2.7 kB)


#2

ya, the interesting line in the tty output here is:

means for some reason your graphiccard cannot deal with 32bit depth and antialiasing. never tried that, so i’d say that could just be a limitation of your card/driver…


#3

Thanks!

I forgot to say that this happens only with Fullscreen.
In WindowedMode, with same settings as above, depthbuffering won’t simply work (as if it would be set to “None”), but it’s still possible to see the box rotate, etc.