Forum

Delay Fullscreen on second monitor - bug?

Somehow delaying fullscreen on second monitor via the fullscreen pin of the renderer does not work.

If attached patch is saved when already switched to fullscreen on 2nd monitor it opens in fullscreen no matter if fullscreen pin is still 0 or already 1 !?
If renderer is on 1st monitor it seems to be fine !?

For me it looks like a kind of conflict between the XML lines:

and

Looks like the first line “overrules” the setting of the fullscreen pin at startup !?

Markus

delay_fullscreen.v4p (6.1 kB)

thats excatly how it is supposed to be. componentmode has priority.

hmm … but this leads to really unlogical “buggy” behaviour of the patch.

Fullscreen-Pin set to 0 but Renderer still fullscreen !?

How would you then patch delayed fullscreen on 2nd monitor without “setpatch/getpatch-Gehampel” ?

Markus

Why not use some combination like OnOpen (VVVV) - Toggle (Animation) - Fullscreen on the first renderer instead of saving in fullscreen-mode?

well the idea is that you use either componentmode, or the pin. why would you want to mix both come into those troubles at all? just set componentmode to windowed and then do the rest with the pin. no good?

sounds good in theorie.

but the problem is, that only using the pin does change both, the pin and also the componentmode.

If you start the patch with componentmode set to “InAWindow” (by editing the xml) everything works perfect. The Renderer starts windowed and goes fullscreen after setting fullscreen pin to “1”.
If you now save this patch again (Renderer set to fullscreen only using the pin) also componentmode is saved as “FullScreen” … and next time the renderer will start fullscreen … no matter if fullscreen-pin is 0 or 1.

If componentmode would stay “InAWindow” after saving everything would be fine … i think !?

Markus

true, you have to save the thing with the the renderer windowed. else it wouldn’t work.

I second @ MSBERGER’s request. I often use little adjustments while performing or otherwise in fullscreen mode and want to save the patch, which lead to weird behavior when starting the patch again if I forget to save it while in windowed mode.

so an option of setting a sort of starting mode or something similar would really make at least my life a little easier

Is there a reason to also change componentmode when changing the pin ?

This is not only causing this firt step of this “FullScreen-strangeness”.

  • Open the “InAWindow” patch that was saved with Fullscreen Pin=1
  • Set FullScreen Pin back to “0”

Normally you would expect the Renderer to be “InAWindow” again … but now it is “Hidden” …

Of course a simple setpatch like

works as a workaround and this “Strangeness” is not a really big issue, but in the “ideal world” there should be a cleaner and more logical way

hmm …

the reason is that vvvv does not know whoe set a renderer to fullscreen. the keyboardshortcut and the fullscreen-pin just send a message.

exactly.

yes.

hmm…after the last action you described the renderer is fullscreen, as is its pin. now you didn’t describe how the fullscreenpin was changed back to 0. if you change it back to 0 in the patch, the renderer will go windowed. you save that. reload. renderer will be windowed.

if you change the fullscreen-pin to 0 using a text-editor instead, warranty is void.