CV.image, AsImage, changing the channel count

I’m trying to use the detect pedestrians node, works with the video input node, but I wanted to run a test movie through it, so I’ve used VLC dx11 and as image to change the channel order, but I’ve noticed that the videoIn outputs RGB8, whereas the VLC is always RGBA, and if I get it to 8 the colours are mixed up. I’m guessing this is the cause of the error
OpenCV: src.size == dst.size && src.channels() == dst.channels()
and that DetectPedestrian is looking for an RGB input, is there anyway to strip off the alpha channel of an asimage? Would this make it work?

can’t you wire the dxtexture through a renderer or a changeformat node beforehand? at least for testing if the node works then…

Tried that, all the formats have an alpha or don’t work at all :(
I can tell the node works as it picks up false positives in my room with a webcam, just need to try it with some relevant footage so I can evaluate it, is there an video player in cv.image?

can you try with one of the cv.image videoin or filetexture nodes? i’m just curious that the node works at all, or the problem is a different one.

i always had struggles when (dis)connecting the input on this node (iirc the detect-object node has the same issue).

so please try:
disable the node, connect its input to a surely valid input source, then save & restart vvvv.

Thats what I was using with my web cam, so I know the node works, I get false positives. The webcam image is RGB8 which is a format I can’t get when using vlc or going though a dx11 renderer. VLC dx9 doesn’t work at all for some reason, red node, but I’ll try a x86 version today


I posted this regarding VLC.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.