Crash when exposing a texture io box

How to reproduce:

  1. Open latest 22.5 preview
  2. Reference Stride
  3. Add Checkerboard node
  4. Add io box for output texture

Thanks for this report. Sadly I can’t reproduce the crash. Any further steps you could tell us? If you repeat those four steps on your end are they still leading to that crash or is there something else you did? Would be eager to get that crash as well because the error message was one we recently added and points to a problem in the way the system loads compile and runtime assemblies.

It only occurs for me immediatly after opening the latest preview. If I have already worked with Stride in another project, it seemed to work fine (don’t see the texture preview in this case though as recently also wrote in the chat). Also it happened both with pre-compilation turned off and on.

That the previews don’t show up when you only reference VL.Stride and use pre-compiled packages is a known issue and is on our list.

Okay, here are more detailed steps to reproduce it on my end:

  1. Open 22.5-258 with pre-compilation turned on
  2. Reference Stride from the node browser
  3. Without closing the node browser search for the “Textures” category
  4. Then navigate to Textures>Source
  5. Place a Checkerboard node
  6. Create an io box for the output texture

can confirm this behaviour


Got that crash and almost same error message when opening the help patch “Overview available nodes” from VL.IO.MouseKeyGlobal by @bjoern

If that is not leading to the crash, try opening the same packs help patch “Use Mouse (IO.Global) with Stride” and then the one mentioned above.

Thanks guys, crash is reproducible.

The crash is fixed in most recent preview build, that the Texture tooltip wouldn’t work will be fixed in next build.

1 Like