Corrupted mesh/x.file in fullscreen mode only?!

I just spend all my money to buy a new superfast laptop to improve my vvvv work. It’s a Dell Inspiron XPS with an Nvidea GeForce 6800 Ultra.

I have a huge problem with my little lowrider on my new laptop. When I run the patch in fullscreen mode the mesh isn’t displayed right anymore and appears corrupted. This only happens when I switch to fullscreen mode!
When I cancel the fullscreen mode the mesh is still messed up. When I set the depth buffer of the dx9 renderer to 0 and then back to 1 the mesh is fine again.

I tried to change the depth buffer while I’m in fullscreen mode but this had no effect. In fullscreenmode it just doesn’t work right. It works fine on my other machine with an ATI Radeon 9600.

Since the mesh looks fine with my GeForce 6800 until I switch to fullscreen mode I hope that it migh just be a setting with my card but so far I couldn’t figure out why. What happens in the fullscreen mode?

Another thing with my GeForce, which is more of a minor problem is that everytime I return from fullscreen back to a normal render window the render window cannot be moved anymore and it has lost its regular windows frame.
I then need to close the window and reopen it and it is fine again.

That the mesh isn’t displayed right is a huge problem since I need to run the patch from the computer with the new GeForce in 10 days for my diploma presentation and I’m really worried about that.

Please guys, any solutuions?
Thanks a bunch

corrupted_mesh.rar (134.5 kB)


i think i can help you about the missing border after switching back to windowed mode. press Ctrl + 8 twice to recover the border.

concerning the messed mesh…have you tried different fullscreen resolutions? does it happen with different meshes?
actually since you say it works on your other machine i’d also consider it a driver problem. if you have the newest driver try an older one…

i have a geforce6800 in a desktop and went fullscreen with meshes without troubles.

good lukc.

Sorry guys !

I simply need to turn off autosize backbuffer and it works…I though I tried all the renderer options but I obviously didn’t try the backbuffer…must be 'cause I’m a little stressed out…
YEAH…I feel so reliefed !!! And that also solved the missing border problem!!!Makes my new laptop worth every penny and I have a good night sleep.

Sorry again and thanks for the fast answer. I just love vvvv and it is truly so awesome that you guys always answer so fast !!!


strange. “autosize backbuffer” should not have any effect in fullscreen. backbuffer size in fullscreen is always the selected screen resolution.

but you say it looks good now?

Yeah…so the crazy thing is…
I just completely reinstalled my old comp with the ATI 9600 card.
And for some weird reason I have the same effect on this machine now, too ?!

I changed my system from Windows Pro to Windows Home. But this couldn’t be se reason, right?
The only thing which is different except the system is that I didn’t install the latest
catalyst drivers for the card…So I guess it must be a bug then and/or a driver issue.

It also effects the frame of the render window when I return from fullscreen mode.
It only works right if I turn the backbuffer off…

But when it is turned off it works…strangely enough
Cheers Jannis

Now get this !!!
Now I would say that it is vvvv bug. And a truly bizarre one I would say…
I noticed that before I reinstalled the system I always had the sytem design set to classic. Now after everything was new I had the new XP style up.

It works fine in the old windows style and the mesh is corrupted only in the new XP

Same for the missing border of the window…

Cheers Jannis