Converting x file to Mesh Geometry Split Assimp DX11 format


#1

Hello , im wondering how to transform an object x.file made in Dx9 from camera and freeframe contour.dll to a Scene Assimp format (obj).
Any idea ?


#2

https://www.blender.org/ can import x files


#3

DX9toDX11 (DX11.Geometry) >> OBJ Writer i posted on previous
[thread](obj exporter Calculating from image a mesh, and bonning and animating it?) but it’s 64 bit…

don’t see why you would do mesh in dx9…


#4

because contour works with dx9 ???


#5

Ok, to explain you my process Antokhio:
im not using 3D softwares
i m drawing in bitmap a form, wich is now converted to a mesh as an .x file from VVVV patch and contour dll functions. im saving my mesh in x.file.
I want to use it in DOPE to obtain animation in realtime on that mesh .
but DOPE is working only in DX11 meshes

i m blocked actually as all examples are using DX11 assim scenefile and Mesh (geometry split) assimp) nodes…

in the example it is said that boundedbiharmonicweight is the lone way to pass a dx9 mesh… but i dont see how to go ahead on it, as i m not a 3d specialist


#6

Sry yet didn’t had time, will check tomorrow morning


#7

thank you anthokio. i heard what you said about using directly the output of contour freeframe (the opencv not working here, and i prefer less ressources consumer).
i tried with 2dTriangle contribution, here is enclosed a patch with 2d triangulated mesh. seems to be ok, but i still do not arrive to insert it properly in DOPE structure_ I would like to use it with the 2D/01 Point Handles no triangle. visually the result will not be Wireframed but SolidFilled._

mesh from image.zip (1.0 MB)


#8

mesh from image new.zip (794.0 KB)


#9

thank you anthokio for the time you pass on it, and thank you for explaining how to install opencv dep on VL
Helas, object exported doenst works with the 2D DOPE example as a scene object… olalalala… the node contour has no entries or output

0:03:03 ERR : Exception occured in TMPluginWrapperNode.Evaluate
00:03:03 ERR : Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index


#10

You maybe need to update dx11 pack, https://github.com/mrvux/dx11-vvvv/releases

Grab latest I guess, there was some bug with assimp I know Vux updated it

image

Also this part I think coming from contour node, maybe there should be som node before output…


#11

i tried to update dx11, but still same issues… grumph… how frustrating !!!


#12

Humph, will check at home


#13

thank you antokhio !
any way to get it worj with the 2d CPU version ? i tried to get the xyz output and indexes inside the boundedweight without success…


#14

Ok, can you assemble patch you have troubles with dope, can’t find anything on examples quickly

put that in pack vvvv_50beta37_x64\packs\dx11\core

Assimp64.zip (2.1 MB)