Command Line not accesible / no nuget installation via command line

Since an upgrade to a new system at my institution, my access to the command line has been blocked due to a security policy

Can I also just download the nupkg and unzip it to …\gamma\nugets, or must this still be registered somewhere?

I have tryed and tested it successfully, but is this a proper way? And how is it for example with VL.OpenCV where the installer also creates other folders like OpenCVSharp?

I might be okay with the workaround or suceed to convince my IT for an exception, but might be also worth having this in mind and to find another way from your side as it could be as well a potential issue for other institutions, universities, schools as well, if students or employees cannot install nugets on their own.

you can do that, but indeed it will fail for packs like VL.OpenCV that have dependencies, which you’d also have to download manually.

i’m afraid i don’t see a quick solution for this from our side. the real solution will be when we offer a package manager. one thought: would it work if you’re running the commandline via the Executor node?

one thought: would it work if you’re running the commandline via the Executor node?

Unfortunately not. Also sending a string results in klilling the process.

But thanks for the reply. I will figure out a solution with the IT.


Last thought: ist it also possible to run the “nuget install” command with Powershell? As Powershell acutally works. I tried it navigation to the vvvv folder and lib folder as well as starting it via the Executer name. If so, which would be the working directory?

Or may running the NuGet.exe with arguments via the Executer-Node another idea?

you need to be in a folder that contains the nuget.exe to use the nuget command.

I think there is option also to add nugget.exe to PATH environment variable, idk this looks valid

But be careful you can mess up it pretty easy

When you start commandline from the gamma menu “manage nugets” you are in AppData\Local\vvvv\gamma\nugets and there is no nuget.exe in this dir but it still works. this cmd window you start from menu must be aware of the nuget.exe path. how do you do this?

You can start any exe in the command line with a temporary addition to the PATH environment variable.

We did still not find a solution for it, but at least I can in the meantime run a cmd window - but the keyboard input is restricted. It works though with the help of a .bat file to start a cmd and run anything inside. But here I’m not aware how and where I should start the Nuget.exe using the SetPath.

My idea would be now to use the Executer node instead to start the nuget installation from vvvv which should theoretically then also work, but as as with the .bat I couldn’t manage ist so far…

Where would I set

  • the path to the “Nuget.exe” (C:\Program Files\vvvv\vvvv_gamma_2021.4.12\lib)?
  • the path to the Nuget directory (C:\Users\XXX\AppData\Local\vvvv\gamma\nugets)?
  • the “nuget install VL.Nugetname -pre” prompt?

As in the following, of course I again have the problem not beeing in the folder of the Nuget.exe.

Or alternatively, could I directly run the Nuget.exe with additional arguments to install the Nuget?

Thanks for any further hint.

Update: playing around a bit more I finally found a working solution to run the nuget installer from within vvvv with the executor node with the following settings:

1 Like