COLLADA plugin

Look’s like you have somekind of slim-dx problem, maybe a scale or empty textures, cause on my renderz both of your meshes are all-right.

collada-tests-DirectX Renderer_2009.09.22-05.12.59.jpg (135.6 kB)

model with skinning from max

worm 10.DAE (760.7 kB)

Hey antokhio!, thanks for the quick reply. I found out that removing the skinning pin the mesh worked great. fantastic. i will check your model

i did some tests with the collada plugin + cinema. just one question, does animation only work with bones,scale, position etc. ? i made a point level animation (animating mesh points) and this animation doesn’t show in vvvv.

is it actually implemented or some error on my side ?

I checked luxology modo. It’s nice 3d program and with plugin can export collada files. Modo don’t have bones at this moment, have morphmaps and this is really cool for animations too. Exporting easy animations is possible (moving, scaling etc.) Works good but this kind of animation is easy to do in vvvv. Unfortunatelly morphmaps animations aren’t exported or vvvv plugin don’t see it (in modo plugin are program profiles to export and with modo profile mesh isn’t visible at all but they are another profiles too) is it possible to collada plugin see this kind of animation?

btw. thanks for great plugin!


and i have second question :) i imported collada file and made vertexbuffer from collada mesh and after that i joined vertexbuffer to a mesh again… Ok and now i still see a mesh properly but a loose texture coordinate and generally i don’t see texture… I tried some repair nodes but this didn’t working or i can’t make it working ;) Is it a not very complicated method to resolve this problem?

thanks :)

sorry for my late reply.

regarding the last three questions:
i’d like to see this point level animation if you don’t mind. the collada file i mean. sounds to me not different to any other animation…

no, morphing is not supported up till now.

hmm i don’t know what you were trying to do but sounds to me that it’s not collada related so better ask in another forum?

maybe not another forum but another topic ;) i just want to know how place the same texture in good coordinates on almost same mesh (almost becouse after mesh split -> vertex buffer split -> whatever -> vertex buffer join -> mesh join) but never mind if You don’t know answer for this problem. Thanks anyway

hi all,
i really love this plugin. i’m using it instead of .x.
But now i have a question, i need to use the skinning (for a character animation) but i would like to use some shading for animated models (i don’t know, for example some reflections or bumpmapping or other). How can i merge a shader with the functions needed to skinning?

well that is rather a shading than a collada question. please start a new thread for this in the shader forum.

@joreg: you are right. In the meantime i resolved, and i wrote a simple shader with skinning.
but now i have another question, that i can’t resolve, about collada. I used many 3d models 'til today, but now i have one that works in different way in 3ds max and in vvvv. I think the problem should be the limitations about the number of bones adressed by each vertex, but i’m not shure and i don’t know how can i walkaround this problem.
here there is the .dae
if you try it in 3ds max (i have 3dsmax9 with colladamax plugin) you can see it deforms smooth and fine. but in vvvv no :(

any hint?

ps. why the skinning transform pin gives me a spread of 240 (if i change the number of bones the number of skinning transforms does’nt changes)

anyway, probably my problem is the 4 bones per vertex influence. there is a way to expand this limit? (i saw in the source code of collada this lines, may it helps?
// There are only up to four influences allowed.
if (displayMaxNumInfluenceWarning && skin.vertexWeights.vcountv > 4)
COLLADAUtil.Log(COLLADALogType.Warning, “There are only up to four influences allowed. Skinning might be incorrect.”);
displayMaxNumInfluenceWarning = false;

        			// renormalize
        			if (blendWeightSum > 0) 
        				for (int j = 0; j < 4; j++) 
        					blendWeights[j](j) = blendWeights[j](j) / blendWeightSum;


hello there

first of all, i do like to thank elias et al. for this nice plugin.

my question is actually more cinema4d-related, but there is nothing i could find on the collada-wiki:

so far, the basis is working. i can load the astro_boy_walking in vvvv.
but i cannot export the file from cinema4d. even when i load the astro_boy in cinema4d (which works fine) and export it to collada without changing anything, i cannot open it again in vvvv, though it seems to be recognized, but not displayd for some reasons.
any ideas? I compared the two files, the original is around 300 kb bigger, and cinema4d deleted several parts… hard to say…

@cznickesz: did you had to change some settings? i can load your testcubes in vvvv. when i load and export them in c4d, i loose the cam-animation…

thank a lot

hello aivenhoe!
Prob. you need to find something like nextgen collada for c4d cause there is more then 1 type of collada files, and you are usin old exporter.

EDIT: Heh, nevermind the following, I had just forgotten to download the addons package for my newer VVVV. ;)


first - thanks for the plugin, so far the amount of things I can intuitively do with ready plugins of VVVV have been amazing! Not much anything I could have done easier by programming it myself, and this plugin’s the last add I really have needed. :-)

However, I am not sure if I am doing something wrong, or if it’s the new VVVV version, or perhaps a broken .zip for colladaloader, but after installing it according to the instructions, I can’t seem to find the Mesh-node for ColladaLoader… I do find ColladaLoader node, but no Mesh. The ‘Mesh (EX9.Geometry Collada) help’ tutorial patch doesn’t have it either.

In case it’s relevant, my vvvv’s version is 40beta23.

The instruction does say to have 40beta21, so is it so that the newer versions of vvvv aren’t yet supported?

how did you download it? addonpack beta23_02?

do you have SlimDX runtime feb 2010 installed?

Hi Guys,

I hope I have sufficiently done my homework, but I have an issue with the plugin - well more of an inconvienance.

I have used the DAE plugin to get some projectiong mapping happening and i managed to export the DAE from Google Sketch Up fine, but the scale was way wrong.

I managed to manually scale it down, and transform it a little to get a great result, but it would be better if I didn’t have to sort of trial and error it.

On the configuration pins for the CollagaFile object there are two pins (Source distance unit in meter) and (Target distance unit in meter) that should do what I want - I think.

But changing these values from default (0) to both high and low numbers didn’t change my model at all. In fact changing any of the config pins didn’t seem to change my model at all.

I am obviously new to vvvv, so i don’t know if I’m missing something incredible obviously. When I render the object using the Collada mesh object, and then transform/scale/rotate the lighting effect, the model is effected - but the configuration pins don’t seem to do anything.

Any ideas. The collada file is very basic - straight from google sketch up - could this be the issue? Not enough information in the model or something?

thanks for the help, I’m loving the program



I have worked out what I was doing wrong!! I hadn’t attached the Matrix transform from the Mesh Collada object to the ex9 effect object.

Thanks to the Collada help file for helping me out with this one.

I have a few other texture questions, i can’t seem to get the textures working on my DAE model. I think it is probably something to do with the scale or transformation of the texture, but I think I will head over to the main forums to ask about this.


I just loaded a patch called ColladaAndSkeleton.v4p downloaded somewhere in another thread (cant find it now)
It opens and shows the astroboy but there are obviously a few nodes missing.
on inspecting the xml these seem to be the offenders:
Missing Nodes:

I dont have the file SkeletonNodes.dll in the plugins folder!
I do have SkeletonInterfaces.dll ??
I have the latest addon pack

Any advice?

look here