Forum

Code editor broken 8(

Hello all!

I have a serious problem I was hoping someone could help me fix.

My code editor seems to have stopped working. If I right click on any editable node it simply does nothing. Both effects and dynamic plugins are effected. I can open modules just fine.

I don’t know what I did when it started happening, but I thought a simple reinstall of windows would work, but it doesn’t! I tried to use an old installation of VVVV that included all my directories and such, and it ended up not working on the new install. I then tried a new unzip of in a new directory, unlinked all in crack.exe on the old install. Then made sure crack.exe on the new install was all green.

Still wont let me edit any code 8(

Is there a way to super-uninstall vvvv so that no settings could be corrupted from my old install?

I have some projects coming up, and it would be great to not have to use notepad to write shaders :p

Thanks!

Jon

sounds superodd,

is there a message in Renderer (TTY) when you right-click a plugin/effect to show the code?

\girlpower has a patch called PluginTester.v4p does that show 3 nodes? and on right-clicking timeliner does it show its corresponding window?

00:02:52 ERR : Error caught in the act: TAddFlow : Access violation at address 00000008. Read of address 00000008
00:02:52 ERR : Invalid pointer operation while Deleting Node of Type ? (EX9.Effect)
00:02:55 : Invalidated cache for C:\vvvv_45beta25.1\plugins\OpenNISkeleton\OpenNISkeletonNode.cs.
00:02:55 ERR : can’t alter existing node. old node with id 1 not found.

These are some messages I get when right clicking on a plugin. This was after I made a clone of an effect.

No message when trying to open an effect.

00:05:13 : Invalidated cache for C:\vvvv_45beta25.1\plugins\StringTemplate22323\StringTemplate22323Node.cs.

That is the standard message I get when trying to open a plugin.

In the girlpower patch, 3 nodes are there. Timeliner opens fine when I right click on it.

Jon

edit: if it helps, I’m running windows 7 64 bit

what’s the output if you try another route?
open project explorer (ctrl + j) and double click the cs or fx document.

when I do that with an effect it pops up a IObox(string) comment box containing the file path of the effect/plugin over the node. This happens when I right click a plugin in a normal patch window but not an effect. It happens with effects when I double click in the project explorer window.

Still no editor tho.

Thanks for your help!

Jon

hmm, i think we’ll need to do some kind of debug session together. visit me in irc if you want to. my name there is azeno, i should be there afternoons and evenings.

Same problem here; brand new install of Win 7 (32 bits), and vvvv_45beta25.1

Typical example: if I open the “shadeyourpixels” patch from the girlpower directory, right-click on an effect node will open the code editor without letting me edit anything.
Putting a Renderer TTY in the patch before clicking the effect shows the following errors:

00:00:08 : Invalidated cache for C:\Program Files\vvvv_45beta25.1\vvvv_45beta25.1\girlpower\GaussianBlur.fx.
00:00:09 - : [ custom settings ]( custom settings ) loaded in 0.007 seconds.
00:00:09 : Loaded node infos from C:\Program Files\vvvv_45beta25.1\vvvv_45beta25.1\girlpower\GaussianBlur.fx.
00:00:12 : Saved node info cache to Temp: C:\Users\TremensS\AppData\Local\Temp\vvvv\node_info_569806406.cache

If I try though the Project explorer, the code editor shows up well, still no luck at editing though.

Tell me if I may help further tracking the bug
T

Ok, think I got the cheat.

Something is apparently wrong with the clone feature, not the code editor itself.

Everything works fine if I left-double click in the patch, type/search for “Template (Ex9.effect)”, and then Ctl-click or Ctl-enter: the clone pop-up shows up and the code editor window that appears works fine (i.e. I can edit the code).

But what I was trying before was by left-double clicking on the patch, then right-click to browse by category, then “EX9>Effect” -> “Template (EX9.effect)”. From there neither ctl-click or ctl-enter brings up the clone window.
Thus the code editor was obviously showing the original instead of a proper clone and wouldn’t probably allow modifying.

Hope this makes sense and helps for fixing.

++
T

@jonferran: until the fix, hopes this route will work for you as well!

helo TremensS,

sounds to me like your issue is unrelated to jonferrans. seems you simply tried to modify write-protected effects. all effects/patches/plugins shipping with vvvv in \help, \effects, \girlpower and \plugins are write-protected. when opening such an effect or plugin in the codeeditor you see it has a + sign after its name in the tab, which stands for “write-protected”.

true though that cloning doesn’t work from the category-view. i put that on the list, thanks.