Forum

CCV 1.3 and 1.2 strange behaviour on vvvv tuiodecoder

Hi, i am trying to use ccv for blob tracking, sending the data from ccv to vvvv using the tuio udp option and recieving it in vvvv using the tuiodecoder node.
I tried all the versions of ccv available: 1.3 - 1.2 - tbeta (the very first one) and here are the results

CCV 1.3
The tracking is working only on a very very small area of the camera and when the blobs go out of that tuiodecoder just does not recieve anything…
Screenshots:
Blobs inside the “working area” are tracked
http://www.freshpatata.it/hosting/ccv v4 issues/ccv13-v4-inside.jpg
When you go outside of that area it just does not work anymore!!
http://www.freshpatata.it/hosting/ccv v4 issues/ccv13-v4-outside.jpg


CCV 1.2
Tracking working on a bigger area than ccv 1.3 but when the blobs go in some edges of the camera view tuiodecoder recieves always 1 1 as x and y coords
Screenshots:
Same as before but the working area is different…here it “works”
http://www.freshpatata.it/hosting/ccv v4 issues/ccv12-v4-inside.jpg
Outside of the working area tuiodecoder recieves 1 1 as coordinates
http://www.freshpatata.it/hosting/ccv v4 issues/ccv12-v4-outside.jpg


Tbeta
Everything is working fine (but damn its the veeeery fist version of ccv :( )
Screenshots:
http://www.freshpatata.it/hosting/ccv v4 issues/tbeta-v4.jpg

I have done tests with win xp and win7 with v4 beta25.1 and beta24.1 and i am using the ps3 cam but the behaviour is always the same…
Why is this weird things happening? do i have an old/corrupted version of tuiodecoder?

Hope someone can give me some tips,
many thanks,
byebye

could you elaborate why you conclude this is a problem with tuiodecoder?
if you are using beta25.1 with its according addonpack you have its latest version.

are you saying that even when touching outside the “working area” vvvvs UDP (Network Server) is receiving data? if not, this can’t be a problem with vvvv, right? if you still receive data it would help to find out how the data received from inside the working area differs from the data received from outside the working area…

you’re right…i just imagine it’s not a ccv problem but maybe a communication problem between vvvv and ccv or maybe mine i really don’t know, i have tried it in different pcs to avoid the “its just my pc’s problem”…

by the way i have done a couple of more tests to see what udp was recieving inside and outside the working area and here are some screenshots

CCV 1.3
What udp is recieving when the blobs are inside the working area
http://www.freshpatata.it/hosting/ccv v4 issues/ccv13-udp-inside.jpg
…outside the working area…
http://www.freshpatata.it/hosting/ccv v4 issues/ccv13-udp-outside.jpg
…without any blob tracked…
http://www.freshpatata.it/hosting/ccv v4 issues/ccv13-udp-noblob.jpg


Tbeta
What udp is recieving when blobs are tracked
http://www.freshpatata.it/hosting/ccv v4 issues/tbeta-udp.jpg
…without any blob tracked…
http://www.freshpatata.it/hosting/ccv v4 issues/tbeta-udp-noblob.jpg

From what i see in ccv 1.3 what udp is recieving when no blob is tracked and when the blobs are outisde the working area is almost the same (can’t really decode what udp is seeing but the strings seems similar). So as you said joreg it does not seem to be a tuiodecoder-vvvv(?) problem…

any suggestion?

Have you tried out version 1.4?

http://nuicode.com/projects/ccv/files

Seems pretty good to me, much faster than 1.3 and a bit more reliable. Otherwise try pressing ‘c’ to adjust the camera calibration. In the past I had problems with the input track data like 10x the area being tracked (or was it the other way around?)

None the less, the most recent version seems pretty reliable.

like hadasi said, maybe a calibration issue. seems most likely to me.
if not already done, repeat calibration, adjust calibration
area to fullscreen, etc…
the xy 1,1 issue on ccv1.2 is known bug when touching outside the calibration area or touching x0,y0 when area is fullscreen.

ok guys thanks for the tips, i’ll try to do a calibration.
by the way in my pc ccv 1.4 crashes on startup…

i’ll update you as soon as i have some new results!
thanks very much

Hey Crash. did you come up with any solution? i think i’m facing the same problem

i think the problem with this is in the calibration.xml

OK!!

FINALLY
It’s because of the config.xml file as hadasi said. but if you want to try it with the video, replace the config.xml with the version from tbeta

calibration.rar (267 Bytes)