Forum

Can't use 45beta25.1

Hello,

I already asked for this problem but I received no solution (probably because my original post was concerning an other problem). So excuse me to post it again.

I need to write dynamic plugins. But beta25 has no copy-paste in the code editor (it’s a punishment to code in these conditions), so I need beta25.1 which solves this problem as far I know.

But in beta25.1, other problem : I am not able to create any new own module, it doesn’t appear in the NodeBrowser so I can’t use my new module.
I did many tests, I still don’t understand what happens. I followed the recommendations of the Root file, and tried to add my paths. The strange thing is that NodeList sees well the new modules… I tried to restart or Alt+E after creating, never works. Or I should say : by miracle, it happened 1 new test module was usable, but don’t know how…

I don’t understand how this release can be used by people. Am I the only one with this problem ? What release is the recommended one ?

Any help would be really appreciated. I’m feeling vvvvery frustrated for months.
Thanks,

Matthieu

25.1 is definitely the way to go.

i don’t understand the problems with the modules. if i create modules and put them in to the modulesfolder, everything’s just fine…

Thank you kalle for your response.

Argh. So I will describe what I did exactly today, during my n-th tentative to use 25.1
Maybe someone will see immediately my mistake.

  • I uninstall previous version (45beta25) with “uninstall.exe” and erase the vvvv directory, just to be sure
  • I recreate a vvvv directory, and put the vvvv_45beta25.1 folder
  • I run the crack.exe, all is green, I quit.
  • I run vvvv, and open the Root.
  • I fill the “contributions” and “my addons” strings with “C:\vvvv\contributions” and “C:\vvvv\myaddons” (I created before these 2 folders beside the vvvv_45beta25.1 one, and also created inside the 3 folders “effects”, “modules” and “plugins”)
  • I save my empty patch “0.v4p” (also tried with filled patches having inputs and outputs, same thing), renaming it for example “Bidule (Animation).v4p” (yes I’m french :-) ) in the folder “C:\vvvv\myaddons\modules” (or “C:\vvvv\contributions\modules”, or at the root of “C:\vvvv\vvvv_45beta25.1\modules”, same results)
  • I close it and open a new patch
  • I double-click in order to insert the “Bidule” node, but it is not in the NodeBrowser. I do Alt+E, same thing
  • if I go back to the Root patch, and search “Bidule” in the output of NodeList (with a Sift), I do not find it
  • I close vvvv and restart it, now it is found in the NodeList, but still not in the NodeBrowser
  • I tried on 2 different PCs (a PC and a laptop), one with Win7 Premium the other with Win7 Pro, with no specially exotic applications on them.

That’s it.
I precise I’m used to create modules since beta23 (but since beta24 if I remember well, I cannot create new modules with “Save as” and have to create a new patch then save it).

Any idea ??

have you try unregister all in crack??
and you have to add your custom folders to rootpatch and save it

  • If I unregister all in crack, vvvv doesn’t launch anymore.
  • And I think well to save my rootpatch after adding my custom folders (I forgot to say that in the list of things I do).

OK, it seems there is no solution, so I will wait beta26 and hope…

well, try re-downloading vvvv, check you don’t have framework 4…
“modules with “Save as” and have to create a new patch then save it”
that is a behavior when you try to modify native 4v module you have to first do Ctrl-Click in line so copy that module to your patch then you would be able to save it… Check the root patch to see how to organize modules correct
because it might not let you to edit vvvv/modules directory
Also try click 4v and do Run As Administrator

Thank you.
Indeed I had .NET 4.0
I removed it to have the 3.5 as the latest one (I used the dotnet cleanup tool and restarted the PC), I ran crack to unregister all, removed 45beta25.1, re-downloaded it and installed it, edited the root patch like before (to add my own folders), but I still have the problem.

This time my “Bidule” module (the one I created in previous test, in “myaddons” folder specified in the root patch) is known, but not the new modules I create in the same folder after the new installation (not seen in the NodeList and in the NodeBrowser). Like if the NodeList would update only one time, when we give it the folders…

I tried to run vvvv as administrator, doesn’t work better.

@matthieu1978
i repeated your steps and can confirm what you’re saying. there’s no need to reinstall .net or vvvv, it’s simply a bug on our side in node info caching. so yes, you’ll probably have to wait for next beta or as a workaround, delete the node info cache after you’ve saved all your patches as modules. the node info cache is located here:

  • win7: C:\Users\USERNAME\AppData\Local\Temp\vvvv\node_info_*.cache
  • winxp: C:\Documents & Settings\USERNAME\Application Data\Temp\vvvv\node_info_*.cache <- i’m not exactly sure if this path is correct. user windows search function in case it’s not.

oh and thx for reporting this one.

OK, thank you !
Your tip works (I clarify for other people in the same case : the cache file must be deleted when vvvv is not running).

cool! good to know ;]

fixed for beta>25.1