Forum

Can't select network adapter in IP node

Im using the IP node in one of my patches to get the computer’s and router’s IP, but there is no (obvious) way to select the adapter to use.

On one machine it worked fine and selected my wireless connection, but on another it chose a virtual network adapter, throwing 120 errors per second in the TTY window almost bringing VVVV to a stand-still. After disabling that adapter it went for the Bluetooth adapter causing the same error. I cant remember the exact wording now as i’m on my mac, but something about "no socket available … " and IP was shown as 0.0.0.0. Only after disabling that one too did it choose (the obvious) network adapter, ie. the only real network adapter that was connected to the network.

All this could be solved by having a dropdown selection of all available network adapters and maybe not constantly throwing an error, but only doing that once : ) Alternatively it could skip to the next network adapter until it finds one that has a real IP and not 0.0.0.0, although i guess thats better done by using nodes to check for that.

I only just started using vvvv, so maybe i have overlooked something, but some help would be really appreciated as my patch will run on several different computers and i dont want to have to disable all network adapters except for one on each machine.

Thanks!

ps. i love vvvv !

hei seltz,

did you notice that IP (Network) returns information about all adapters in your system as a spread? so you could yourself check for the slice that does not have the 0.0.0.0 ip, right?

you could do like this

GetIPFromSpecificInterface.v4p (6.2 kB)

Thanks @joreg and @sunep.

I cant check the patch right now, but your right - i didn’t notice that is outputs a spread (doh!!). In that case, yes your right i will put in a little check. Im sure thats what i will find in that patch - thank you for that!

Im still curious why its throwing so many errors though… i wouldn’t think that anything in vvvv keeps throwing an error on every frame and i havent seen anything that has so far. Sure there is errors that come up in the TTY, but not like that. It was slowing down vvvv so much i almost wasn’t able to scroll to the place where it was, to temporarily delete the node. Disabling the network adapters themselves was the easiest way.

Another slightly unrelated topic, is there a way to check for “real” CPU usage? It just gives me a spread with the values for every core, but id rather just know how much CPU vvvv is using in total. I also couldnt find a way to display actual FPS for vvvv and not just what i set in Mainloop.

Thanks again!

Use Timing (Debug) to show actual frame rate.

you know PerfMeter (Debug)?

it is perfectly possible that something throws an error every frame. but the IP node should rather not, since it is usually updated once and does not repeat any operation every frame. usually pressing strg+f9 shows the error-throwing node colored. when tty slows down everything you can close it temporarily to speed the gui up…

There are some troubles from a seven update since 2 months: ip diseappearing.
Do a windows update first, and .net too.
I had this on a computer during one day and some of my users also