Cant run setup.exe with admin rights

as already stated here


i still have the problem, that vvvv is the only software at our company my admin is not able to install with her admin rights.
i have no admin rights, i cant test and explore the problem, but i still think that the problem has sth to do with “Herausgeber: unbekannt”. a message appearing when double clicking setup.exe on a german win version.

all other software we were installing had a proper “herausgeber”(whatever the english term is)

someone had the same problem?
is it possible to create a setup.exe with a proper “herausgeber” or certificate or i dont know, i am just guessing.

thank you.

can you try running an admin powershell/command-prompt and running setup.exe from there? when i do so here, the unknown-publisher dialog doesn’t appear at all.

command-prompt? we already did that! no success :(

as mentioned, vvvv is the only software behaving like this.

hei @hrovac

hmm have you already tried run it on different user in the same pc? i meant create another user as administrator and try to install vvvv in that new user.

just a wild guess and i hope it work.

hi artifak,
thank you for your response,

we tried also with the account of the admin, no success.

ok, so still no idea, but

  • please post a screenshot of what you get when you run setup.exe
  • has this changed between beta35 and beta35.2? can you still run setup.exe of beta35 or any previous version?

then: what setup.exe is doing is nothing magic, nothing really vvvv specific and therefore can all be done manually:

  • besides installing everything thats listed under Dependencies at the bottom of this page: (all of which are non-vvvv specific)
  • the other thing that is mandatory is registering the thirdparty activeX lib\thirdparty\x64\AddFlow5.ocx

doing that registration manually goes like this:

  • open a command-prompt (as admin)
  • navigate to vvvv50beta…\lib\thirdparty\x64
  • run the command: regsvr32 AddFlow5.ocx
  • note: yes, even on x64 systems the command is called “regsvr32”
  • you should get a confirmation: “DllRegisterServer in AddFlow5.ocx successful”

that is it. now you should be able to run vvvv. if this registration step fails, please post a screenshot of the error message here.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.